Performance issues sculpting landscape

The UE5 Editor is barely useable when trying to sculpt the landscape. I have water in my level and I’m trying to sculpt the landscape around the coastline. The editor is continually rebuilding textures and when I’m moving the mouse with left button down, its skipping severely so I’m not actually able to sculpt where I want to. , The editor is showing around 100fps. I do keep seeing the message LogD3D11RHI: Timed out while waiting for GPU to catch up. (0.5 s) (ErrorCode 00000001) (00000000) in the log. I have been able to reduce the number of these messages by turning off Affects Landscape on the water system.

Are there any settings I can set on the editor to increase performance in this area?

Its worth noting that when I’m not sculpting, the FPS is around 100, as soon as I left click and drag, the FPS drops to 4-5. I am using World Partition, and I’ve unloaded everything but the area that I’m currently working on. For some strange reason, UE5 is using 16gb ram.

I encountered this problem recently. By any chance do you have ‘Enable Edit Layers’ on? If you do, turn it off and your fps should return to normal.

No I’ve not been using edit layers. I have followed advice gleaned from other posts and switched to DX11 instead of DX12 and have fewer issues. I also have disabled real time preview, and bought a 3080 TI. But the Editor still randomly struggles with performance, mouse input, and still get stutters and freezes when navigating around a map in the viewport.

Ah dang, I’m sorry you’re still dealing with performance problems :frowning: try closing out any extra windows ( content browser, details, outliner, etc) maybe that will help.
What size is your landscape?

8129 x 8129. I’ve decided to run without realtime preview as this speeds up the editor responsiveness.