Perforce Trouble

First of all. I don’ t know if this is the right Subforum but I didn’ t find a better one. I’m now trying for, well days to get Perforce up and running. I’m nearly there but things don’ t work as expected. My setup.

P4D 2018.2 1751184, P4V 2018.4 1753667
3 Windows 7 pro Machines + NAS. One machine has The perforce Server installed. The remaing two have an unreal Engine 4.21 installation + P4V.
I have a NAS drive mapped on all three machines where the UE4 projects is located.

Problems I ran into and maybe wrong ways I fixed them.
When I first installed the Server and connected with a client I added a new Workspace, like the UE4 docs suggest (also following this tutorial
This will bring up a wizard to add files to your workspace. This works actually a just single time. The second time I create a workspace the wizard doesn’ t appear and from that point I have no idea how to add files to my workspace. According to the docs.
To add files/folders to Perforce, first select the files/folders in P4V and then Right-click and select the Mark For Add option.
Once I created a new workspace in P4V the Tree doesn’ t show any files at all I could add. I found the filter option “show entire Computer”. But when I browse to my UE4 Project and right click a folder or just a single file, there is no add option.
This problem got my stuck for quite a while. When I watched the youtube tutorial I linked above I noticed than once he added files (through the wizard) to his workspace he opens his project from the workspace rather than from the source location. This got me to the idea to set my workspace root to the inital UE4 Project folder. From that point it seemed to work. Both client machines could connect to the Perforce Server and found the workspace. Btw. I had to remove the host entry in the advanced settings of the create workspace dialogue so the client machines where able to connect. I also edited the typemap accoring to the docs. The dummy project I’m currently testing consist of just some nearly blank levels, some materials and some blueprints.

My big problem is the check out and check in process total doesn’ t do what it should do. For example I open the project on both machines and make sure the source control is working. I check out a material on machine A, edit it a little hit save… and “could not be saved” without touching it on machine B. I close and restart on both machines and start doing exactly the same. And it works 2 times 3 times and suddenly “cannot save”. Again reopening the project on both machines. I checkout a material on machine A try to check it out on machine B wich gives a warning. Machine B than shows the file as checked out but I can open edit and even save it while it’ s checked out on machine A. Machine A of course can’ t save it after that. This doesn’ t happen to a particular machine. Sometimes it’ s A sometimes B. It’ s totally weird. These are just some examples. Seems to happen completely random.

To get around this I tried. Using different kinds of Depots. Normal Depots, Streaming Depots. Used the superuser on both clients. Created individual users for both machines. Added a user group, gave them various kinds of permissions. Tried all kinds of settings in the create Depot dialogue. It just doesn’ t work. For our next project I’ll need to have 2 or 3 people working simultaneously on a project. So I’ pretty much stuck at the moment. Any help is much appreciated.

Edit: I tried more things. It simply doesn’ t work at all. Now I installed the perforce server on a completely different computer. Also a windows 7 pro. This time I created a shared folder on this machine and mapped it as network drive on the two workstations I’m running the Unreal Engine on. Again the same behaviour as described previously. I also changed the engine version to 4.20 wich also was no success. What I also wonder. In the docs several icons are described. A red checkmark for files beeing checked out. A blue checkmark for “checked by another user” . A yellow exclamation mark for a newer file version. All I get is the red checkmark. I checkout a material on client A. Nothing happens on client B. I try to check out on client B it gives me warning file could not be checked out. After that I get the red checkmark on client B, too. After that I make a change on client A, save and check in again. Again nothing happens on client B. File still has the red checkmark on it. I open it and make changes on client B and I can save. I would think this is exactly what Perforce should prevent. Two people overriting each others files. I don’ t know either I’m doing it completely wrong or this is just broken.