Perforce SSL not working as of 4.10

Hey all,

First of all want to say 4.10 is fantastic so far!


As the title suggest I seem to be unable to connect to my perforce server through an SSL connection any more. I have tested it on 4.9 and it was working fine however upon upgrading to 4.10 it no longer works. All my details are the exact same between the two versions.

Here are the errors I receive:

If you have any questions feel free to ask and I’ll get back to you ASAP.



Just upgraded to 4.10 and having the exact same issue.

Mine is an existing 4.9 project. Perforce connects fine in 4.9, doesn’t connect at all in 4.10. Tried disabling plugin, restarting, enabling plugin etc.

So I just traced the connection attempt and can confirm via wireshark that UE4 editor isn’t even making an attempt to connect to my P4 server. The error seems completely internal with zero packets transmitted to the destination server.

This is easy to reproduce in a clean 4.10 project.

Same problem here. P4 working fine in all of my 4.9 and earlier projects and other things I use P4 for (command-line client is fine, P4V is fine, etc.) Not sure what has changed in 4.10 that is causing this.

I just tried updating my P4V client to the latest, no change.

I’m narrowing down the problem. It seems that something is spuriously reporting or detecting an error in the source control config dialog. However, UE4 editor can still work correctly.As a temporary workaround, you can type the correct info into the UE4 editor’s source control config settings, and then without clicking any other buttons, close the UE4 editor. You can then run the UE4 editor again and it will correctly connect to source control the next time it starts. Note that I haven’t tested this with an expired ticket (my previous login ticket is still valid). Ignore this, incorrect. Only cosmetically displays as correct, still actually not working.

This kind of works. At least the source-control icon turns green when I start up. But I don’t see any source control status icons on assets and trying to refresh status fails and submitting from the engine also fails.

Oops, you’re right, it doesn’t completely work. Seems most of the functionality still throws errors. Hmm.

Hello everyone,

Leaving a message here to let you know that I’m looking into this problem. I’ll let you all know if I have any questions or have any additional information to provide.

The P4 source control plugin module doesn’t seem to come with debug symbols, so I’ll have to build from source to see what’s going wrong. It will take me a few hours (I haven’t set up 4.10 for a source build yet).

Edit: it does come with the pdb, I’m just not getting some type info in the debugger. Will keep looking, but can probably find what’s wrong before I do.

Did you get a chance to step through this in the debugger? I may pull down this weekend and see if I can get anywhere.

Have you been able to repro this on your end ?

I’ve attempted to step through it, however I can’t get the VS debugger to utilize the symbols correctly for the perforce source control module. I think I need to build from source, and I haven’t yet had a chance to set that up. Sorry :frowning:

No worries. I have a deadline for this Friday, after that, if this hasn’t been resolved I’ll pull down master and hammer on it for a few days.

I think I found something. It seems that someone added a bunch of
#if USE_P4_API ...some code... #endif inside all the functions. The problem is USE_P4_API doesn’t seems to be defined anywhere. Meaning, when you compile it, all you have are just empty functions.

I saw that too, but it is hard-coded to true here. This seems to be part of the changes for the VS 2015 support.

Hello everyone,

It appears that this has already been reported elsewhere and you can find information surrounding that report here: Perforce SSL Failing in 4.10 - Programming & Scripting - Epic Developer Community Forums

We hope to have this fixed soon, but please be aware that we do acknowledge that SSL is having issues in 4.10.

Thanks . Are you guys not using SSL internally? For shame, may as well leave your passwords on a post-it note too :wink: