Perforce SSL Failing in 4.10

After upgrading to 4.10 (and VS 2015), we’re no longer able to connect the editor to our Perforce depot over SSL. It fails with the following message:

LogSourceControl:Error: P4ERROR: Invalid connection to server.
LogSourceControl:Error: Connect to server failed; check $P4PORT.
Failed client SSL connection setup, server not using SSL.

Has something changed? Is it the use of p4api-2015.1 when compiling with VS 2015?

As a side note, when I run “strings librpc.lib” on the p4api-2015.1 version (as mention here) there is no mention of OpenSSL. There is, however, when I run the same command on p4api-2014.2. Was this new version not compiled with SSL support?


We haven’t yet updated the P4 source control plugin to use the VS 2015 version of the SSL libraries. In FPerforceSourceControlProvider::LoadSSLLibraries() we (probably) need to add manual loading of the correct dlls. I’ve added a ticket to get this addressed.

I can confirm that after uninstalling VS 2013 and 2015 and then reinstalling only VS 2013 and rebuilding 4.10, that the problem goes away. We will need to wait to upgrade to VS 2015 until this is sorted out.

For reference, the issue ID is UE-23364.