Perforce check-out option disabled in editor

When attempting to check-out assets within the editor when saving, the option to check-out and object is grey / disabled.

Within the check-out window selected files can only be made writable.

I can still manually check out those files within the Perforce client.

I’ve followed every guide for setting up Perforce for UE4 and am still unable to check out files from the editor.

I’m the only one using the Perforce server. The files are not checked out before hand.

Because someone else is already checked out the files. They have to check in, so others can work on the files.

Then that someone is you. Maybe submit your changes / check in the files? Or give us more info, logs, concrete error? etc…

There are a few reasons that I know of why that button can be greyed out:

  1. The assets are checked out by someone else, or yourself in a different workspace.
  2. The assets are not at the head revision.
  3. The assets are already checked out in this workspace.
  4. The assets are not under source control, or are being ignored for source control purposes.
  5. The editor is not connected to the server.
  6. Source control integration is disabled.

Thanks for the reply Tom,

I’ve checked everything you mentioned and still get the grey box in the prompt that appears when saving changes to assets in the editor.

I can go into the Perforce client afterwards and check-out the file just fine. The prompts in question don’t appear once the assets is properly checked out.

Could it be a server settings that I missed? I followed the steps in the documentation article on Perforce.

Note that I tried this on another computer with a clean install and had the same problems.

This turned out to be a corrupt Perforce database causing the issue. This is resolved now.