Download

Pending Kill Bug

I’ve been getting this problem lately and I don’t know what it means. More specificly, i get:

“Error Cannot access ‘StaticMeshComponent_4885’. It is pending kill. Property: ‘CallFunc_Array_Get_Item3’ from node SetWorldLocation in graph ‘click’ in blueprint ShogiBoard”

ShogiBoard is one of my blueprints, and Click is a function. Anyone knows what’s up with this error?

http://puu.sh/nUEdM/c56c7c6aa0.png

http://puu.sh/nUEdM/c56c7c6aa0.png

http://puu.sh/nUEfk/516e0e762d.png

http://puu.sh/nUEg8/5802c51239.png
http://puu.sh/nUEh3/b03268032d.jpg
http://puu.sh/nUEi0/0c50753dc0.jpg

I get this too:

Error Accessed None ‘CallFunc_Array_Get_Item3’ from node SetWorldLocation in graph ‘click’ in blueprint ShogiBoard

I was getting those when trying to grab some information from a couple of arrays. I ended up having to put an IsValid check where it was telling me the problem was. Turned out the blueprint was trying to access an actor referenced in my array that was in that purgatory state between being valid and being destroyed.

I’m not at my computer right now, but if I don’t see that this has been fixed, I’ll upload a screenshot of what I’m talking about as soon as I can.

Please do! :smiley:

This is what I needed mine for. I’ve got an array of goal items and I have guardians that travel from one to another. Occasionally they’ll be told to go to one that has just been picked up, but hasn’t quite been “destroyed” in the code yet. This was throwing me the same error that you were getting.

This is how I solved that:

As you can see, my code gets all actors of the goal pickup class then makes the check to see if it’s valid before going into the rest of my code. If it’s not valid, then I just have it pick another target.