Download

PC to Mac issue

Hi,

I’m new to the forum and UE4 and I’m experiencing a few difficulties.

I’m currently undertaking a Game Audio module for Uni and have an academic licence. I have been provided with a template project to learn the basics, which I have used on the Uni’s PC lab computers. At home I’m a Mac user and was under the impression that I could just take the project, or .umap files and open them without issue.

On trying to open the project I have been presented with these errors:

Screen Shot 2014-10-09 at 13.27.50.png

Clicking either yes or no results in this message

Screen Shot 2014-10-09 at 13.28.03.png

Clicking yes then results in this message

3dc409b2b445624e8c0031422fbb25ad59468990.png

Clearly there is some kind of issue. I have tried using an original copy of the project file (the same one originally used in the labs) However the same thing happens.

Does anyone know why this might be happening? Or, what can be done to work around the problem?

Any help would be greatly appreciated.

Many Thanks

There are any number of issues that could be the problem here. If you can’t launch the project because of a compile error, find your uproject file in the Finder (probably ~/Documents/Unreal Projects/[Project Name]), select the project by single clicking it, and then go to the Services menu under the Finder menu and look for “Generate XCode Project”. That will allow you to generate an Xcode project when you can’t launch the project. A similar option is available in Windows by right-clicking the .uproject file.

Open the Xcode project and try to compile. It should tell you what the problems are. If you’ve used any platform-specific #pragmas (#pragma region, e.g.) that could be causing the problem. Also, if you’ve used any built in VSS constants that aren’t defined on the Mac, that could cause a problem, as well as if you’ve called any system functions not available on the Mac. You can wrap platform specific code using


#if WINDOWS
// Windows stuff
#endif

or


#if __APPLE__
// Mac Stuff
#endif

Once you have your error messages, a path forward should be clear, but if not, post your error log here and we’ll help you out.

Thank you for the prompt response. I have followed your steps and this message appeared in terminal, when I tried to generate an x-code project

Screen Shot 2014-10-09 at 14.14.40.png

It appears there is something missing. Yet this is the file I have used on the PC computers. Does this error make sense to you?

Thanks

What does your [ProjectName].Build.cs file look like? I’m not expert on UE4’s build system, but it looks like a dependency issue of some kind.

Also, have you installed a recent version of Mono?