Download

PC Shuts down only with Unreal - TwinMotion

Hi!

I’ve built a PC for architectural visualization.

CPU: Ryzen 9 3900X

GPU: MSI Trio 3080 (new, intalled)

MoBo: ASUS Pro WS X570-ACE

PSU: Focus+ SSR-850FX

Built it, tested it (cinebench, 3d mark, multi hour gaming, Flight Simulator) all good, all nice.

One day, wanted to fill a landscape with trees in TwinMotion, 10 trees and it turned off suddenly.

Ok, tried again the trees, same thing.

Then, tried Unreal 4.27 on this PC, boom again shuts itself down. Sometimes while dragging a reflection sphere, sometimes when changing a material, some times rendering light on preview, or in production. It is jus dissapointing. Kernel Power event id 41.

Cant figure out what is UE doing to shut down my pc.

Any ideas?

I even lost a GPU it was an EVGA 2080Ti (burnt, total loss) magenta lines all over display no memory detect, etc).

Coukd it be overheating?

I believe it’s overheating issue.

I recommend cleaning your P.C.
Check your cooling system and turn off you’re overclocking.

Hi Limanima, thanks fot the reply.

My temps on CPU always below 80 C on a Artic AIO (temps checked via Ryzen Master and HwMonitor).

My case is a Fractal Meshify 2 and even bought 2 more 140mm fans, totalling 3 140mm front intakes and 4 exhaust). Full fans kick in at 70C for the CPU. In my opinion temps are sweet!

Weird thing is that i have tried:

  • CineBench
  • Heaven
    -Aida 64
    -Halo
    -Apex Legends
    -Microsoft Flight Simulator

All of the above perfect, not a single issue, even at ultra high settings. But the issue appears on Unreal-Based apps (Twinmotion-Unreal Editor).

Hi Striker.x, thanks for the reply.

As mentioned above, my temps are below 80C for the CPU and GPU, Aida 64 30minute test, all good.

As it is a new PC the thing is shinny new! no dust, no nothing.

As soon as the problem went crticall I turned everything to default, MoBo settings, RAM Speed, GPU an CPU to default as well. Same thing.

Forgot to mention i have 32GB RAM Ripjaws.

Ive tried renderings without the glass panel, changed powercord, direct to wall outlet, etc.

But the issue continues only with UE Based apps.

Sounds like you have a puzzle to figure, but I do not think it is that tough a puzzle at that. Are you sure your power supply has sufficient wattage to power your whole PC even with your graphics card fully throttled up? I say this because you need to power up many parts and you can not afford to not be too low on power. GPUs do run hot, personally I aim for 80c max.

UE4 will try to run any project at the highest frame rate possible in the editor, this is why any project or scene will send the temps up and max GPU usage. You can try limiting the frame rate of the project you are working on or setting real-time to off in the viewport

You can also try under volting your GPU to substantially lower the power draw with only dropping the performance by a bit. To be on the safe side of things, check to see if you have enough power to support your system and double check to see if your GPU is not over heating which may be caused by over clocking (which you claim is not) or a power supply that is not working correctly.

Hi ANFETOMA,

Since your computer is in excellent condition.
But I still recommend monitoring your power supply, ram, CPU, GPU, in idle mode…
And Fully turn off your antivirus while editing.


Maybe it is a Twinmotion bug(s).
Even UE5, Twinmotion bug(s) still exist.
Unfortunately, I cant help you in this matter.

Try running OCCT for 10m on both CPU and RAM.

Sudden power loss without a bsod indicates a hardware issue.

Could also be driven by something like a liquid cooler water temperature exceeding a certain threshold.