Pawns push objects even with DISABLED Physics Interaction

Hey guys. How can I make it so that my character pawns will stop pushing physics objects? I have these little guys and some cubes and a bridge, which when they come into contact they just push away with ease.

i tried disabling the Physics Interaction option in the Character Movement component, but it does nothing, same results. I also tried to set the Initial push Force Factor to 0 and the Push Force factor to 0 (from 750,000), and they still just walk through objects.

I want my pawns to not be able to push, I am going to push for them. The Add Movement Input for the little pawns not set to Force.

I appreciate any input here. i created a forum thread too.

I’m wondering the same thing. I’m planning to use destructible physics crates as a blocking gate but since the player can just nudge them out of the way it defeats the purpose.

Bumping as I am having the same problem but haven’t found a solution so far.

The last days i also had some work that crosses this theme.
I do not see it in your picture, but: Is there a checkbox for gravity?
If it is then uncheck this.
Is there a Physics constraints tab? If it is: Lock the location and rotation.

Maybe that helps :smiley:

I ran into this problem and I found I had to change the player’s physical material. The friction in particular had to be set to zero because otherwise objects would be moved as the player brushed past them.

Like other people I started by clearing the Enable Physics Interaction box, and that stopped the player pushing things directly. I think the point here is that controller inputs don’t normally work through physics. When the player presses the forward button, it just moves the player, it doesn’t put a force on the player and allow the physics engine to move the character. Because of this, there is a fudge so that the player can push physics objects, and the checkbox turns the fudge on or off.

If the player is already moving, or the player is struck by a physics object which is moving, this doesn’t apply. In this case the controller inputs are irrelevant, and the interaction is driven by the physical material which is assigned to the player character.

That didn’t help me much… I can still sprint-jump into large steel cubes, punting them into the distance with my head.
Perhaps there are more ways than one to get these results?


i have taken a little time to solve your issue. It is quite easy, but it is always once you have the anwser :smiley:

Go into your character BP and select the Movement Component.

Then in the Details Panel there is this section (view the picture):


What i did is: Change the “Initial Push Factor” from 500 to 0. That solves your problem.

You can dive deeper into this and you can try changing the other values, but for now this works.

Cheers :smiley:

For me, the problem was that the static meshes I had added to my character had blocking collision enabled. They were what was actually pushing the physics object, not my character. Once I set all my other components to No Collision, then I could see that unchecking Enable Physics Interaction was actually working.