Pawn with Skeletal Mesh falls despite 'Enable Gravity' not ticked?

Hey guys,

The title says it all. I have ‘Simulate Physics’ ticked.

If it helps, whenever I try to add forces via AddoFrce blueprint node, the thing jitters and moves in a direction different to the force axis specified (i.e. down and to the right when applying force in positive X).

Any ideas? Is there something specific to the skeletal mesh (in my case, a spaceship) required for normal physics to work as expected?


What does your physics asset look like? It sounds like you might have some interbody penetration which is causing the ragdoll to go flying


So we fixed this issue - my artist did some tweaking and changed the way they set up the skeleton for the spaceship. Additionally, we used a physics asset to override the skeletal mesh component’s own physics stuff, and this asset of course had its own ‘Enable Gravity’ tickbox.

However, we’ve encountered a new issue - if we change the collision settings in the physics section of the mesh component (which aren’t overriden in the physics asset), to say ‘Collision Enabled’ under the ‘Collision Enabled’ drop-down, just above the Object Type and Collision Responses check-boxes, the pawn with skeletal mesh will not move at all. Adding forces, adding torques, it doesn’t matter - if it’s set to have collisions, it won’t move an inch. This is regardless of what tickboxes are used or the ‘Object Type’ setting.

Is there something we’ve missed?


Would you mind posting a screenshot of your settings for the mesh component as well as the entire object? (I assume this is inside a blueprint)

Are you using a movement component?

Sorry to revive an old thread but I have exactly the same problem. The skeletal mesh falls constantly and whenever I update the rotation via inputs, it goes crazy and moves out of map. Is there any development on this topic?