Pawn stuck constrained to z-plane even when constrain to plane is turned off

I have a custom pawn with a custom movement component based off the floating pawn movement. A while back I enabled constrain to z plane to fix something and now I want it off however, the asset stays locked in the same z position no matter what I do.

As you can see constrain to plane is unchecked.

Hey Ecburgess0113,

Thank you for reporting this issue to us. I have tried to replicate the same z axis constraint on a character blueprint and was unable to do so. However, I am currently in UE 4.8.1. I see that you’ve been working out of UE 4.7.6 according to your post, could you please try to attempt this in 4.8.1?

Looking forward to hearing back from you, thanks! :slight_smile:

Hello Samantha, I was able to work around the issue by subtracting from the z axis on position when not in contact with the ground.

Hey,

I verified the issue in 4.7.6, 4.8.1 and 4.9. I’ve submitted a Jira report to our developers, referenced as: UE-18035

Have a great one! :slight_smile:

Hey Ecburgess0113,

I heard back from one of the developers regarding the bug I entered. They believe that I’m seeing a UI issue while you’re seeing a runtime issue. Could you please explain further the issue that you saw before you fixed it by setting the z-axis back to 0.

For example:
Did you have the z-axis set to -25 and have the constrains unchecked when you noticed your pawn was still being constrained to the z-axis?

Looking forward to hearing back from you, thanks!!

No at the time I wasn’t doing anything to mess with the z-axis I merely checked constrain to z-axis in the detail panel and left it like that for a while. Then when I didn’t need that anymore I tried unchecking it but, the pawn still behaved as though it were constrained to the z-axis.

Were you able to replicate this more than once? I’ve went back to 4.7.6 and tried to reproduce this the way that you’ve explained and I haven’t gotten it to happen yet. I do notice that the UI shows that the axis is at 15, but I’m not restricted to a specific axis.

Thanks so much! :slight_smile:

Hey Ecburgess0113,

I have not heard from you in quite a few days and for this reason, I must mark this question as resolved for tracking purposes. If you still have further questions for me, please feel free to ask here. For any other questions, please post a new thread to AnswerHub.

Thank you and have a great day!