Pawn Sensor doesn't work on spawned actor

Hi There,

I have a blueprint with a pawn sensor in it. When I manually place it on my level it works fine. When I spawn the the same blueprint the pawn sensor never seems to activate. I put breakpoints on begin play and when the actor is spawned it does got to begin play, but onseepawn never gets activated.

I place one actor and spawn one right next to it and the manually placed one works fine while the spawned one doesn’t. I don’t see anywhere where I can activate the pawn sensor in the blue print.

Can someone point me in the right direction?



I am also very interested in an answer to this.

I was having the exact same problem and this is how I solved it.
There is a spawn AI from class node as well, let me show you how I have used it in my spawner actor;


In your AI Character Blueprint’s Class Defaults, try setting Auto Possess AI to Placed in World or Spawned instead of just Placed in World. I’m not sure if that’s necessary in this case if you’re not doing any work with an AI Controller, but I think it’s worth a shot.

Let me know if that helps. If not we can continue to investigate and find another solution.

Have a great day

1 Like

Hi Sweet Mate,

Thanks for that I can’t wait to try it. Will that work with a Pawn sensor also It looks like you may have been using some of the other AI tools which I haven’t played with yet.

My actor is basically a dumb weapon emplacement so I just used a pawn sensor.



Hi, I’m new to this and I have the same problem, which solution worked for you, the Newest probe but it still does not work and the other one does not really understand the process

Hello Sean L and tried what you say but it still does not work

If you believe that this is a bug, please provide me with a detailed list of repro steps that I can use to create the issue on my end, otherwise it’s tough to tell exactly what you’re doing that could be causing this issue.


Hi, thanks for the help.
The steps I’m taking are these:

  • I have my bot that when it detects the player it starts to follow, this works fine only if I drag the bot on the scene manually.

  • At the moment I want my bot to be spammed, so I do the following:

This makes my bot generated correctly, but it does not follow the player or do anything. Finally in my Bot I went to the section that you mentioned and I left it in the following way.


it still does not work :frowning:
Again thank you very much for your help.

I really need help with this.

Try using one of these nodes that you can get access to by getting the AI controller.

It also may be worthwhile to take a look into the perception component in the AI controller to handle stuff like this.

I had the same problem; Actor placed in world worked fine but spawned actor wasn’t.
Solution: Change “Auto possess AI” from "Placed in world’ to “Placed in world or spawned”.
Works great now.


I running into a similar problem when worked with BP_ThirdPersonShooterAI in ThirdPersonKit.
TPKit using PawnSensingComponent in a BP_Sensing_Pawn which is used as a ChildActorComponent in BP_ThirdPersonShooterAI. This is causing the AI not working properly when spawned because the BP_Sensing_Pawn as sub-class of APawn will try to spawn its default AIController when Initialized which is happened within the construction scripts of the ChildActorComponent and it’s forbidden as mentioned here

the solution is to spawn an AIController manually and posses the BP_Sensing_Pawn, then all works well.

Thanks friend! ! all afternoon investigating. This resolved everything! ! ! ! ! so simple…

Such an easy fix. You saved my life! Thanks

There is so many things broken in UE4, Pawn sense requires a work around for its limited usability, Clipping object overlap causes overlap event to fire multiple times, custom object channel can’t fire overlap events… Also custom Trace channel breaks after some time working…

In Unreal eyes, how exactly are you supposed to build AI with f*** eyes if everything is broken? Do i need to roll back an update?

HI Clones1201,
How does one do this exactly?

thanks dude, this is the solution.