Pawn object spawns twice


I’ve created a new Pawn class blueprint and added a few components in it (a few spheres of different sizes). So, when I add the blueprint into my level and play it, one of the objects (the first and biggest sphere) spawns twice, in a different location.

There is limited functionality in the blueprint yet, and certainly no functionality for spawning characters.

What reasons could there be that an extra object from the Pawn class I created (and use in my Game Mode, by the way) is spawning?

Thanks in advance.

Can I see a screenshot of your pawn blueprint? Maybe the component is duplicated.

Here are the screenshots of my blueprint, editor, and level. Also, note that for some reason, this only happens sometimes. Or maybe it happens all times, but sometimes it’s not in the camera’s field of view?

Hmmmm honestly I can’t see the reason of the problem that you are describing. However I must say that you are using a pretty high number of mesh components for a single blueprint. Is there any specific reason why you did it like that?

Edit: Maybe the problem is related to that. Have you considered using separate pawn blueprints for each planet?

It’s true that it may be related to that… otherwise, perhaps it could some kind of setting that I configured for automatic spawning? Not sure.

Anyways, I haven’t thought of creating seperate blueprints for each planet, until now. I thought it would be better organized that way, but I’ll try seperating them instead to see if there’s a difference. The reason I did that, was because I am unsure of such practices (when to create a new blueprint? what blueprint class [actor/pawn etc.] to use?) since I’m still in the early stages of development- hopefully things will clear our in the process.

Thanks for the help, will try seperating the components and see if the project can be implemented this way.

I suggest making an actor blueprint for a base planet class, since every planet will move similarly I assume and when you create them on your scene you can choose a mesh for each planet. Then if you want specific behaviour for a planet you can create a child blueprint from your Base Planet blueprint and expand on that.

Thanks for the suggestion. That seems to have resolved the issue (creating seperate blueprints for each planet), which I’m still not sure how to explain.

I’ll probably be asking more stuff along the way, since I’m still new, or re-open the thread if this happens again, but that’s a good start.

Thanks! [can be marked as resolved]