Pawn movement problem with rigid body actors in Multiplayer (replication)

We tried to solve this for quiet some time now, but did not found any solution. The problem is when a pawn interacts with rigid bodies as a client in multiplayer, it shutters a lot on both sides ( pawn and rigid body). The problem get worse with higher ping. With a Ping of 100 ms it is nearly impossible to have interaction between pawns and rigid bodies.
I have attached a video showing the problem in the first person example map.


Are you using the Pawn class or the Character class? The reason I ask is because the Character class contains predictive movement network code within the Character Movement Component, which helps with this exact thing. That’s why I’d typically recommend either using a Character class for multiplayer, or creating a similar code setup inside of your Pawn class to help deal with this.

Sorry I forgot to mention this. Its a character with unreal’s character movement component. The video there is exactly the the first person template. The only thing changed is the mass of the boxes and enabled movement replication for them.

I have a few more questions:

  • Does this occur if you are not running the game in multiplayer? (if you just PIE with one player)
  • Do you have a project that you could provide so I can take a closer look? I haven’t been able to reproduce this on my end using my networking test project. It seems to be running smoothly on my end.

It does not occur when you play singleplayer or you are the server.
I think its a problem because replication of rigid bodys and character movement are handled differently.
Here is a link for the test project:

Like I said its basically the blueprint first person example project.
To test it just make sure “dedicated server” is enabled or you set “number of players” to 2 or more and move with one of the clients.
If you set the ping to 100 ms via console command “net pktlag=100” in the client, and then run into the boxes everything explodes.

we tested this in all engine versions, and its the same result in every version even in 4.1

Hey WAll,

I have reproduced your issue and entered a bug report, which you can track using the link below:

Thank you for your report.

Have a great day