Download

Pawn falls through floor when gravity is enabled, despite having a capsule collider

So I’ve been trying for a long while to get gravity to work with collisions. I want my pawn to fall to the ground and collide with it, but right now the pawn just falls straight through.

I’m using the standard third person template skeleton mesh with the default animations applied.

Here’s what the settings look like for gravity and collisions on the mesh:

50c87f4c3f1086ac32724a2ba99e8f3423999aba.jpeg

Settings for collisions on the capsule collider:

fdd031baac44e8eb35306fb7f23daf8fc0ea26d7.jpeg

So what’s going on here? I know there’s nothing wrong with the mesh or mesh settings because the player character uses the exact same mesh.

Is this something unique to pawns only?

Hey Bandit,

Check to see if your floor has a Collision on it. because even tho your character has a collision, the Floor needs to know it’s suppose to stop whatever it comes in contact with. Also try changing the Collision Presets for your Mesh. I see you have it set to No Collision, try setting everything to block all because just like the floor, the mesh needs to know he needs to stop. Lastly this might not work but try Parenting the Capsule to your mesh.

I’ll look more into this and get back to you if i find out more…

Thanks for the reply, Override.

The floor already has a collider and unfortunately, I tried your suggestions to no avail. Parenting doesn’t seem to change anything and changing the collision presets on the mesh to BlockAll simply ragdolls the pawn as soon as it spawns (even in mid-air).

Perhaps there is some way to disable ragdolling, but still have collisions using the capsule collider?

Hi Bandit (love the name btw)

Here is a couple of things to try…

  1. Check to make sure that the player start area isnt colliding with the floor. if it is the collision is often ignored and the player falls right through.
  2. check to make sure “Simulate physics” isnt on for your actor. should be under class defaults.

There are heaps instances of this over at the answers forum area.
e.g.

https://answers.unrealengine.com/questions/191663/actor-falling-through-terrain.html

Let us know if none of these work and ill have a look when i get home.

Playing around with this I notice turning off Simulate Physics on GhostMesh fixes the floor collision issue.

Thank you for the help, everyone. I managed to fix it by creating a static mesh component with rendering off, which is parented to the capsule collider and that is then parented to the skeleton mesh, but this time I turned off Simulate Physics for the mesh. The pawn now falls to the ground and collides.

However there’s two new problems: The capsule collider (and therefore the mesh) bounce a little bit when hitting the ground, which looks pretty weird for a humanoid character who doesn’t have springs for legs. Any idea how to turn off this bounciness?

More importantly, I can no longer move the pawn about, I tried to test this by using the transform gizmo while detached from the player, but there’s no transform gizmo anymore.

Here’s what the new setup looks like:
98980bab5af96a360b791c04c11bc9c759d9cb6a.jpeg

Character Movement Component?

I don’t see why I would need that though, I was able to move it perfectly fine before (via C++).

I’ll give it a go in a little bit, I’m reinstalling Unreal 4 at the moment.

This is what I’ve got at the moment:

e57ec86eab4753ffbaa6f4a8f9f51cf08a0b4200.jpeg

I’m not really sure how the Pawn Movement Component works but it’s making no difference as of right now.

Just to sum up the issues I’m still having:

  1. Pawn falls to ground and collides but bounces like a rubbery ball upon impact.
  2. The Ghost_BP(self) part of the component menu never updates it’s position. When I try to move it via the transform gizmo in-game, it just won’t move.

I’d really appreciate it if anyone can help me solve these remaining issues.

Bump. I could really use some help on this.

Still can’t figure this out. Anyone with some answers?

#1 fixed it for me. Seems so simple in hindsight. Thank you.

I had similar issues. However, when I looked into my “Visible Collision” viewport, I saw that no collision actually existed. No wonder I was falling through certain spots.

It was starter content rocks for me that were not working right. In this case I was able to turn the Collision Complexity to “Project Default”, But I also found that I could set the collision to to complex in the top bar, and then back in the “Collision Complexity” section set it to “Use Complex Collision as Simple”