PathTooLongException when running "Setup.bat" for the source build

I’m trying to run “Setup.bat” after downloading the zip file from the GitHub UnrealEngine repository, release branch (4.9). At the end of the setup, I got this error:

Failed to download 'http://cdn.unrealengine.com/dependencies/2466157-4ecb0085873
048178dd6d2b8872eea79/81594c92fcec0b95d7d0b47ad36aef8d2605c8b8': The specified p
ath, file name, or both are too long. The fully qualified file name must be less
 than 260 characters, and the directory name must be less than 248 characters. (
PathTooLongException)
Press any key to continue . . .

with 1.8 MiB remaining on the download/setup. I use Windows 7 Pro x64. Anything I can do to resolve this?

1 Like

The error is clear, wherever your downloadig to is leading to a certain file exceeding the max limit on charactersin a path which is 255 inn windows.

Right click → save target as → save it to something like C:\ue\ or something so that it can be as short as possible.

Hope this helps
Don’t forget to accept an answer that best clears your question up or answers it so when the community finds your question in the future via search/google they know exactly what you did to fix it/get it going.

Okay, I downloaded it manually. Where exactly does the file go then? The current path “Setup.bat” is located is in “/UnrealEngine-release”, but I cannot find the folder “Setup.bat” is using to download files to.

Hey joe.ds-

Running Setup.bat creates and fills a number of folders that are rooted in the same file path where Setup.bat exists. The error that you’re seeing is due to the full file path from the drive root is too long. The easiest way to solve this is to move the folder that contains Setup.bat to a folder closer to the drive root and then run Setup.bat again.

Cheers

Doug Wilson

I moved my “/UnrealEngine-release” folder to the “C:/ue4/” folder and ran “Setup.bat” again. This has solved my PathTooLongException.

I just changed the name of the folder to be smaller and it worked through this step…

Thank you

This might be a very old post, but it just helped me with ue4.20 oculus branch - thank you!

helped me with 4.20 as well. Would be nice if Source came with a clear detailed set of instructions with some basic troubleshooting tips in a pdf. Like most software this century.

thank you so much.you just saved my life.

there are two ways you can solve this.

  1. add \?\ before your path. this enforces using the extended path length. for this, you might either modify the script or create another one. e.g. c:\long path => \?\c:\longpath
  2. this one you should check but I am 99% sure it will work. just simply run everything from an admin powershell console and not the traditional CMD. but if PowerShell didn’t work then use the following link to enforce activation of the extended path policy. here is the link: strong text
1 Like

Wow, what kind of high risk projects are you working on?

the seame to me. tks a lot!