Download

'Patches' failing

Whenever I attempt to generate a patch for a project with unreal engine I constantly get the AutomationTool failed, build unsuccessful (Result: 3). I have tried looking up fixes for this but have only come across ExitCode: 5 (basically every code but the one I am dealing with). I have also tried creating a new project (using the First Person built-in template, adding a few new objects in level to ‘patch’ in) only to get the same error.

Any suggestions on how to resolve this? I have been following https://docs.unrealengine.com/latest/INT/Engine/Deployment/Patching/ but with no luck.

Thanks for your time

Log:

bump.
Could really use some help here and would greatly appreciate it.

Did you ever figure this out? I’m seeing the exact same thing.

Maybe is not exactly same problem, but some times the UAT would be occupied by some other things. There two ways to make it work: rebuild the UAT or restart your OS. Hope it helps.

When this fails, is everyone else seeing their \Saved\StagedBuilds\ folder getting wiped out? I’m guessing the error (can’t create handle) is because the file it’s trying to open just got deleted. Just not entirely clear on why the folder is getting dleted as part of the patch process.

Sorry for the late response, no, I have not solved it

I will try this however I am not sure if that is the issue

I recently ran into this issue when I was trying to figure out how to make patches.

I was getting the same ‘ExitCode=3’ and later realized I missed a button from the Release build that’s supposed to generate a .pak in the …[ProjectName]\Releases[VersionNumber]\ directory.

Make sure when you create your release build that you have the ‘Store all content in a single file (UnrealPak)’ button checked so that it makes the .pak file. The patching build will look for that file to diff against and for generating a new patch.

Here are a few suggestions on a related forum thread: