Particles randomly rolls when parent actor is moving with 180 yaw degree.

Greetings. 4.18.1 version. In the video, particle mesh gets random roll rotation when parent actor is moving slowly only with -178+178 degree of world yaw. Roll effect is greater when playing in dedicated server.
Particle system is based on P_dirt_wheel_kickup(tire track emitter) from Vehicle Game from Vault.

Thank you for your report. We will begin investigation into this issue as soon as possible. If we are unable to reproduce the problem, or need more information, we will follow up with some additional questions for you. Otherwise, we will post an ‘Answer’ once the issue has been logged in our bug database or we have a solution for it.

Hi, I’ve uploaded small sedan project to google drive link text

I haven’t been able to determine what’s causing the weird mesh rotation in your project, but disabling the Inherit Parent Velocity module seems to fix the issue. I am not sure why this module is causing issues because in my project it has all the same values and it works fine.

If you want I can send you my sample project through the UE forums.

Hi Zedokus,
Unfortunately I haven’t been able to reproduce this issue on my end yet. I’ve modified the tire track emitter from P_dirt_wheel_kickup to match the parameters you are using in your screen shots, I’ve got it attached to the “Sedan” from the Vehicle template in a new project, and the particles do not have the random roll rotation.

My guess is that a socket or a bone is rolling slightly and causing that rotation at low animation values (small speeds).

If you are able to provide some clear repro steps to reproduce the issue in a new project, please let me know and I will investigate this further.

Yes, please send it.

Here it is, please let me know if there’s anything else you need.
https://epicgames.box.com/s/naf2a7m6191rv1v3kd2rmq8riciq3nbz