Download

Particles doesn't loop when render a movie sequence

Hi all,

I have a trouble with the sequencer. When I put a particle emitter (cascade) in the sequencer, particle doesn’t loop when I render my sequence to a movie (AVI). It is rendered in the Editor when I play my sequence, but only the first seems to be rendered during the export. I already search on this forum, and use some tips like: disabling “auto activate”, activate particle by using sequencer track and changing the finish state. But nothing works :frowning:
Does anybody alreday get this kind of issue? How to solve it?

I was perform a small test with Niagara system, and that’s works! But I want to use existing Cascade particles.

Thanks

yes, strange indeed… you could try your level BP on ‘begin play’ that will play the particle, then when finished take the output and plug it back into the ‘play’… and loop it that way… maybe?

this is the ‘new’ event director… Calling Events through Sequencer | Unreal Engine Documentation

maybe you can make some sense of this… and since it’s in the sequence, maybe it will continue to run… i used the old ‘simple’ event track, i suppose i’ll need the new one soon enough (smile)… good luck

I found a fix. Though this topic is a little older, I’m posting in case anyone else ends up here looking for the same answer, like I did. The same thing happened to me. Particles would freeze during a render, seemingly after one loop, though they would loop fine in the sequence. I tried unchecking Auto Deactivate within the Particle System, which was a good suggestion by someone else, but the particles remained frozen. So along with unchecking Auto Deactivate, I also found that in the Particle System settings, Seconds Before Inactive was set to 0. I changed this to an arbitrary number of 10, since my sequence was less than 10 seconds long, and this solved the problem. So changing the Seconds Before Inactive to a number greater than the number of seconds within your sequence may help.

1 Like