Particles disappear in Casecade viewport?

Like my title says, cascade keeps having some of my particles show and others not. Like real time is checked and everything. (Made sure to see if I couldn’t find a solution.) Like it is just black. I tried to see if I just wasn’t aligned in the viewport but I am. I can see the wire mesh and everything when I turn that on but for everything else I am just like, “what is happening.” I made a particle before this and it works alright aside from the size by speed not working for whatever reason??? But it is a duplicate, renamed version of the same working particle- it just doesn’t work.

hey hey QWire, I suggest to try the search function on answerhub next time as this is a very often recurring question.

In Cascade, Click in the Black area outside of your emitter module list and then go to the details panel and Find the Fixed Bounds settings, and increase / decrease the bounds as necessary, in your case you will want to make the rooms size the fixed bounds of the system, or approximate as the center of the system is always the center of the bounds so if your fire is on a wall you may want to increase the bounds only in the direction needed to fill you room.