Particle system becomes faster when built (deployed)

I have a level, with some particle systems, all of which has the same issue: when I launch (deploy) the project the particle systems seem to speed up.
I created the particle systems using Cascade, and inside Cascade editor they seem fine:
Here is a video of it.
When running the preview or simulation in scene editor, it behaves the same:
Video here.
However when Launching it from inside the editor, or from the deployed file, the particles speed up, and overshoot:
Video here.
I already tried it with an empty project, and default particle system template, and still get this.
Please if anyone has any idea, knows a solution, or what i did wrong help!

If any further data is required, I will post it on request.

Workaround: when deploy in scene, go to properties of particle and change the valeu of “custom time dilatation” and try to decrease the default “1.0” to something like 0.8 or 0.5, and see if make some result

I hope that helps !

Yaay it works. Nice workaround, fairly easy to automate through blueprint/code.
Thanks for the help!

Hi defrost256 -

I am attempting to reproduce what you are experiencing and currently am unable to do so. Can you provide a sample project that reproduces the issue and attach it here or provide a link to download it? In the meantime look at the attached test project and feel free to use this project as a base.

Thank You -

Eric Ketchum

Test_Project 4.8.3

Thanks for the reply Eric!

Fortunately since I reinstalled my OS, and UE I seem to be unable to reproduce it. Unfortunately my original project still has the issue, so I suspect I screwed up something in some settings, I am yet to find.

I created a clean up version of my original project downloadable here.

Thanks for the help again.

Sorry, i´m really try to help you. If the solution did not work for you, just say and i try to find another solution. No need to click down vote :confused:

Hello -

I looked at your clean project and am not seeing any difference between the PIE and Launched version of the Particle System. Have you tested this version of the project after installing your new OS and made sure that you are on the most current video card driver for your OS?

Thank You

Eric Ketchum

Yes, I have tested it, also I installed the most recent video driver, and I was able to reproduce the problem, it is most apparent when using attractors, or moving the emitter around, so I created another Test project, featuring these conditions, downloadable here.

Is it possible, that the Editor has a setting, that causes it to run on a different speed, or measure distances differently from the built game?

Thank you for the replies, if you have any other ideas, I would be happy to try them.

Hi defrost256 -

There does appear to be a bug in relation to the Line attractor. I have entered a report as UE-20242. As we investigate the issue further I will post back here.

Thank You for your help tracking this down -

Eric Ketchum