Download

Particle only Player Character

So having mental road block, but I want to basically want to have like FPS setup, but instead of the arms, etc just basically have a particle system, so I don’t need a skeletal mesh setup really.
However I need that so I can use the default character movement stuff. Am I just stuck working out the aspect of a custom player controller? Or should I create some super simpleton skeletonMesh setup?

Missing some better way to manage it?

Noting I have it current setup in just “cheating aspect” where I pull the FPS arms back enough that the camera can never see them. But was looking for the more appropriate option / way of doing this.

Just delete the arms + add a particle system to the camera :slight_smile:

ca76734167a1982be0735278c9e22f6ca8e03a9a.jpeg

Thanks I tried that last night, but it messed up the whole character system, for some reason, but tried it again this morning, and things ok. But then again i do find odd things happen if i’ve been in the editor for hours. Rebooting tends to fix things at times. Thanks for the helps.

Just out of interest, what kind of odd things appear when you use the engine for some hours? :slight_smile:

usually around components, and sub editor windows not wanting to do just right. For example last night deleted just the arms mesh, saved, but from that point on just would fall through the world no matter what. Note I still had all the other default components. closed editor, made this post, went to bed get up, see your reply open back up and poof works like I would expect. Have had problems where the windows like the material editor, or mesh editors don’t want to work just right for instance go to drag an arm out from a material node and the box will appear to list the available options but the list won’t render right only shows about 6 items, or if I search at times it will not return something I know it should return. So I close editor and open it back up and poof all good again.

In regards to the particle, best way to sort of make it “stick” a bit better? so for example to just toy around some, i used the p-fire option, as the player runs around the flames get spawned behind as the player runs around. I know this is cause the emitter is firing but is doing so in the world space that is behind so the particles then end up behind the player. Trying to figure out a better way to make the particle or the construction of it with the playerCharacter to work better. Thoughts.

I think enabling “Use Local Space” under required should solve your problem :slight_smile:

ended up using a combination of local, to get it rendering at the location i needed, but also needed to set the particle to be PSA camera facing to keep my player velocity from affecting the particle system.