Download

Particle light module clipping through geometry

Hi guys

I have another little problem with my particle fire: The light emitted from the light module in the particle system clips through everything, be it a static mesh or a BSP brush. The usual suspects don’t solve the issue either (unaligned geometry, lightmap res, etc).

Any ideas?

Cheers,
Michael

Particle lights don’t cast shadows I think

Hmmm, that would limit the usability of the light module a bit in my setup. Is this intentional, i.e. do I have to use a ‘real’ light if I dont want any clipping…?

I fixed it by replacing the particle light module with a point light. It works as intended now.

Particle lights are intended to be cheap because we expect you to use a lot of them and for them to be relatively small: sparks or flares for example. Rendering dynamic shadows for hundreds of lights would be impractical from a performance POV.

I can see a case where you would want to use a single light (an explosion for instance) where you just want the convenience of editing it in Cascade rather than using blueprint and for a single light having the option to cast shadows would be useful. I’ll add it to our backlog to consider for future features.

I’d really appreciate that. It would definitely be a useful addition.

Do you treat each particle as a light source? Why not use a proximity-based volume / cluster to dynamically reduce the amount of light sources in the equation?