Particle cutout with texture grayscale

hi, i recently discover the cutout feature on CPU particle for reducing overdraw :


It work fine with rgba texture, but i did not manage to make it work with Grayscale texture.
I tried to change the Opacity Source Mode, but none works.

Thanks in advance for any help.

there is often no use for a grayscale texture. try setting its compression to alpha, that works for me.

I creating my Grayscale texture on Photoshop (2458kb), i tested all the setting compression, none works for the cutout features. If i export RGB Texture it works, but the texture is bigger (9832Kb).

if your texture compression is alpha all but “OSM Alpha” work.
so unless you are messing something up that should work.

Here a texture who does’t work for me, can you tell me if it works for you ?
Thanks for help :slight_smile:


can you show the texture settings in the texture viewer as well as how you set it up in cascade?

setting it to OSM Red or color brightness should work.

Badly,it doesn’t work :S

send me the texture if possible (can attach a small version to this thread in a zipfile)

link text

sorry for the late reply, i was rather busy.

resave your texture as a RGB instead of grayscale.
apparently ue4 doesnt like it when its a grayscale texture.
You wont lose any memory or other performance due to that.

Thanks for help !