Download

Particle Collision works in editor, not during play

Hi all!
Got this werid issue where my particles collide with the floor perfectly in the editor and bounce off the floor with damping… but when I press play (launch, PIE or make a build) the particles just go straigth through the floor like there is no collision at all.
Been trying to figure this out for a while now…my floor collision seems to be fine…if anyone got an answer you’d save my life!

Thanks for taking a look!

Hi Khazual,

I tested this in our 4.6 preview build in the following instances and could not get the results you’re getting. Could you test my setup on your end and elaborate more if you’re still seeing issues?

For my test I used a new default scene. I used the P_Sparks particle from starter content.

  • I placed a single instance of this in the editor
  • I placed a Blueprint that had the particle system in the components tabs
  • I placed a blueprint that spawned a particle system once I hit PIE.

In all three of these setups I saw the same results with the sparks spawning and bouncing off the SM_Template_Map_Floor mesh.

There may be something setup in your particle system incorrectly that may not be registering the collision.

The attached image is not working. Can you possibly update this as well. I merged the double threads and deleted the additional comments that were not needed.

Thanks!

Tim

Had same issue. Set collision checkbox for “ignore actor” to off. It’s on by default. That’s the one that messes it up.

For me, the answer was unchecking “Drop Detail” under Performance under Collision Module