Part of brush missing, and no collision

Having an issue when trying to enclose my level with box brushes. I can do 2 of these “walls” just fine, but when I do the 3rd and 4th, part of the brushes “mesh” becomes invisible, and my player and projectiles can go through these areas. The brush size is (50, 10000, 2000) each.

Update: I’ve removed all but one wall. The wall is fine, until I move it to this end of the map… Really odd, I’ll try to use static meshes and get back.

Update: Ended up restarting the editor, same issue. Removed all walls, then tried moving one of my cone brushes into this area and they became distorted as well. I thought one of them had some odd breakage because some faces were floating a couple units away and there was a hole in the mesh. This turned out being two brushes too close together. Once I deleted both brushes, I was able to add all new brushes for walls and ramps, no issue… This is really strange, I mean I even tried overlapping two cone brushes again this time and no problem. Problem is solved for now but I think this may be a problem that will occur again, perhaps you guys are already aware of the issue and it will be fixed in the next update?

Were your BSPs overlapping at all? Overlapping BSP can cause BSP ‘holes’ which give the anomalous behaviour you’ve described.

Well I thought of that, then I deleted all of the box BSPs and added a single new one, and had the same issue when putting them in a certain area. But then I realized there was a cone bsp touching the side of where i was placing the walls. So now that I think about it, this must have been the issue. I didn’t realize this would happen. I’ll try to reproduce the problem and see if converting to static mesh resolves it. For now this seems to be the resolution, thanks for the information :smiley:

I have the exact same problem and I don’t quite understand what is the problem exactly, it seems to me that it is because there is two brushe’s corners that are too close to each other but if that is the problem, I don’t know how to fix it, changing the order in the brush settings changes the invisible part of the brush, does anyone understand what is going on ?
Thank you, Eresea.

Same issue here. I find it happens more often when altering BSPs. In the attached image in the top frame everything is fine but if I move the verts on one part it causes the anomaly to occur on other parts and the further I pull the verts the more the angle of the anomaly changes.

Hi Baer,

Are you using a subtractive brush here as well? Additionally, what version of the editor are you currently using?

Version 4.7.6
Not using Subtraction brushes.
BSPs are not overlapping, all surfaces are snapped to the grid flat against each other.

I tried the convert BSP to Static Mesh option which removes the anomaly, but it’s not very efficient to have to convert everything each time this happens just to whitebox a level.

How many brushes do you have in your level? Additionally, how many of them are using nonstandard shapes?

10 in that scene. Just the arch above the doorway is nonstandard. But I’ve seen this happen with flat walls and floors also. It’s like there’s a subtraction brush there, but there isn’t. If I move any of those affected brushes away from the area they are fine, but placing them back shows the anomaly again.

I restarted a new map, put in some walls and everything was fine. I moved a few verts on the BSP and all hell broke loose. I’ve attached the umap file for reference.link text

What version are you using now?

Hi everyone,

I was finally able to reproduce this and have entered a bug report, UE-15621 to be assessed by the development staff.

Has this been fixed? I just lost an hour or so’s worth of work because I was working in ortho and didn’t realize my brushes were getting corrupted. I’m in the unreal tournament map editor 4.11.0-2926870+++depot+UE4-UT-Release

  • I was duplicating and vertex manipulating the same brush often
  • Sometimes as a duplicated brush moved away from it’s pivot I would move the brushes verts closer to it’s pivot every once in a while
  • Also I just noticed that brushes that were previously fine are now corrupt :frowning:
  • I tried moving a brush away from any other brush to see if there was an issue with intersection and it was still messed up

Edit : Restarting the editor and opening the map opens the map with all the corrupted brushes looking like they are deleted. They are still there but they are fully invisible rather than have the odd face still drawing.

The temp fix for this was to convert the BSP brushes into static meshes. You can do this in their properties menu.

Hi AlexM,

At this time our resources are dedicated elsewhere. Unfortunately, I do not have a timeframe of when this will be addressed. Having said this, Baer’s suggestion is the best possible workaround for this error.