Download

Parenting one mesh to another in blueprint. Not following animation.

Good day.

Can someone please give me advise how to solve this problem:

I have a blueprint with player ship. It have animations and it’s simulating physics and I set **Set All Bodies Below Physics Blend Weight **so I can use animation and physics at same time. Ship have idle animation while in the air.

So… Now I need to add a cockpit mesh to this blueprint. I tried to parent it to ship mesh and even bind it to socket, but It’s just not following animation of the ship. It following the transforms, but not animation.

So how to make it work?

A master pose component perhaps?
It’s hard to tell what you are doing or why a ship would even be a skeletal mesh with animations in the first place.

Ship have multiple animations, states and blend by bones. So I don’t think you can do it without skeleton.

Looks like master pose component is what I need. Thank you, my friend.

Well… Looks like Master Pose Component not exactly what I need here. As far as I understand Master Pose Component require meshes to have same skeleton. I just want to bind something to my main mesh. Like cockpit or, let say, a first person camera from the cockpit. And it should follow the in air idle animation of main mesh of the ship. And the only way to do it is to skin it to one skeleton? And every time I need to add something to it I will need to skin it into skeleton of the ship? And how to deal with the camera? It also not following animation.

This is so strange. No easier way, really? I Unity all you need to do is to make anything you want a child of the main skeletal mesh and it’s just works. Following all movement and animations.

So… I managed to solve the problem. The problem was the root bone. I tried to attach cockpit to the root and by a some reason it just not working that way. So I created one virtual bone in the root bone and bind my mesh to that bone. It working the way just fine.