Parenting glitch

Using 4.7.1

I made a [Parent] phys box.

I made a new blueprint [Child] and select [Parent] as the parent.

Set the [Child] inherited box to be invisible via ‘Visible’ setting.

Add a “ResetLevel” console command as an action on player.

In editor -

In game on first load -

In game after first load and triggering ResetLevel -

seems like whatever is instantiating the actors is skipping instance specific overrides on load, but it corrects them when you call ResetLevel

Am I doing something weird or is this a legit bug?

Hi Taisaku,

I attempted to reproduce this in 4.7.2 but I couldn’t get your results. Could you try downloading the new 4.7.2 hotfix and try it again?

If you can still reproduce the error, I have a question about your setup.

Set the [Child] inherited box to be invisible via ‘Visible’ setting.

It sounds like you are just unchecking the box under the Details panel, is that correct? Or are you setting it via blueprint?

I am setting the [Child] Visible setting via the checkbox. This should override the default value for that instance shouldn’t it? (I am installing 4.7.2 will comment again when i get a result)

Yeah it should. That’s what I’m seeing in 4.7.2.

4.7.2 same issue, maybe my project is corrupted.
Just to be clear, im not setting this on the map editor, im setting it to be hidden on the Child’s blueprint and it only bugs out when its packaged, PIE works fine.

Ah okay! That did it. I didn’t realize it was in a packaged game. I’ll investigate this further and post back here soon.

Heres a new project in 4.7.2 in PIE the childrens inherited box is hidden, but when you package for windows they are visible (and no longer fixed by restarting level) -

Thank you for the report, I was able to reproduce this issue in 4.7.2. I’ve created JIRA UE-11381 and our developers will be investigating this issue further.

As for a workaround, the only thing I found so far is to set the visibility in the parent blueprint. Doing this makes it work correctly but going off of the way you have this setup it may not work for what you are doing.



No worries, as long as it’s known to the devs and in line to be fixed, I’m happy.

Hi Taisaku,

This is now fixed in our latest internal build. You should see it working correctly in a future update.



Awesome! Thanks!