Download

Parent Socket's "Browse" Option shows no Sockets/Bones to attach to Character (Default 3rdP. Skeleton)

Hello,

I imported a character into UE5 which shares the same skeleton as the default 3rd person character, and then created a spine_03 socket ( named Rifle_Socket ) as shown.

As every video and documentation says, I proceeded to add static mesh component to my skeletal mesh ( the respective panel is in the top right of the screen).

The problem is that I cant type anything in the Parent socket “name box” and nothing happens when I click Browse. It gives me neither bones nor sockets to attach it to.

To test things out I placed a skeletal mesh in the level and snapped the rifle to the socket by just clicking them. And this works.

I tried attaching it through a level blueprint but it still didn’t work.

I did the same with a new project, with the default 3rd person character, i.e, made a socket in the skeleton, and tried adding a mesh to it but same thing happened. I had no options to add it to.

Anything I missed or did wrong? I’ve tried anything and everything I’ve watched or read so far, and have no Idea why it won’t give me socket options to attach the rifle to.