Paragon Wukong Q_Flip_Fwd_Montage : Plays but no animation

I have run in to this problem with multiple Paragon Character Assets, so I’m positive it’s just something that I don’t understand. I’m able to use all of the existing Anim Montage assets, but if I try to create a montage from an animation and use it, it doesn’t appear to work. The PlayAnimMontage node fires, but the Character doesn’t play the animation montage, or even appear to be affected.

What I’ve done is

  • Created an Anim Montage from the Q_Flip_Fwd animation that comes with Wukong (just right-clicked the animation and hit Create->Create Anim Montage)
  • Added an Input Action and mapped it to a key.
  • In the Player_Wukong Character BP (Where all of my character controls that are working are), I just dropped in a InputAction event for the new input
  • I linked the input event to a Play Anim Montage node and selected the Q_Flip_Fwd_Montage
  • I also pulled out a Print String node and printed the output of the PlayAnimMontage node, which prints the length of the animation on screen when I hit the key (not 0, so it’s firing)

The only difference that I’m able to find, with my limited understanding, between the Anim Montage assets that come with the Wukong assets, and the one that I’m generating is that the Q_Flip_Fwd animation affects the whole skeleton, whereas the attack Montages that come with it (and work) are only the upper body. That being said, I don’t understand where that would make a difference; just that it may.

For anyone finding this because they have the same problem.

As expected, it was just something that I didn’t understand. Since the character that I started with already had everything in the AnimBP setup for the Attack Montages, I was able to just fire off a Play Anim Montage node and select those and they worked. From that, I got the impression that the Play Anim Montage node was self-sufficient. It is not.

I’m learning Unreal Engine the same way a baby monkey learns not to mess with tigers, and that is by poking it with sticks etc and seeing what happens. That being the case, I still don’t fully understand Slots and Slot Groups and what all they can do. What I have learned though is that Animation Montages are assigned to a slot. You can see which slot they are assigned to if you look to the left of the timeline in the montage. The Play Anim Montage node seems to just queue up a montage. You still need to have the slot setup in the animation blueprint somewhere before it will be applied to the character.

The animation that I wanted to use was in the DefaultGroup/DefaultSlot, so I just dropped that in just before the final output pose, and, behold, the animation worked.

2020-12-04 13_57_02-BeanAndTator_pltfmr - Unreal Editor.png

Hope this helps someone because a part of me did not want to admit on a public forum that the problem was me.