Download

PaperFlipbook Blueprint with physics/rigidbody

Hi guys i’m trying to make a blueprint that contains a flip book animation and reacts to physics. However no matter what I try i’m having no success at getting the physics to work.

Heres what I have done

  1. Create my sprites and outline the collision areas
  2. Created a flip book animation from my sprites.
  3. Create a PaperActorBlueprint
  4. Assign my flipbook as default in the blueprint
  5. Add a capsule as a child of the root (flipbook) in the blueprint
  6. Tick simulate physics on the capsule

The physics options on the root/flip-book itself are greyed out why would that be? Do I need to add a rigid body to the flip book?

  1. Add the blueprint to the scene.

The result is the object animates in mid air.

Im sure that this is something so simple however I am unable to find a solution or documented approach anywhere.

Is the flipbook sitting at the bottom of the capsule? Make sure your characters feet and bottom of the capsule are at the same exact height.
If tthats not the case, open a new 2D project with starter content and check out the default character BP to see how it is done

Hi thanks for the reply, I am not using character controller (as stated above PaperActor ) as it is not an object that takes controller input, it is just an in game 2D object. I have my character working fine

So I found the solution, thought I would post it for anyone else. It was simple enough, what I was mission was a physics component in my blueprint. After adding ProjectileMovement component the sprite reacts to gravity and force

Ah spoke to soon, the sprite/blueprint ignores any collision detection and continues to fall through other object. I have tried setting the capsule collision within the blueprint to block all but had no effect. Can anyone give me a few pointers in setting up a sprite with physics (if I drop a plane sprite into my scene with 3D physics selected in the sprite editor the sprite has no physics and stays in the placed position.

– Update ----
Managed to get sprite physics working by the following

  1. Remove capsule and Physics component from blueprint
  2. Select blueprint instance in scene oultine and tick Simulate Physics from details panel

This however has to be done for every instance, there is the Simulate Physics option available in the blueprint however it is greyed out/disabled. How can I enable the option in the blueprint??

sorry to resurrect this ancient thread, but changing Collision Preset to Pawn fixed it for me.