Paper2d Tile map size wrong and not rendering on standalone

I know another thread for this already exists here. But, it was marked as resolved without the bug being fixed.

Using the “Get Map Size” node in BP reports a different value in PIE and standalone. This only seems to happen if the tile map is spawned into the level, if its already in the level and saved it works correctly.

To reproduce create a tilemap, place it as a component in a blueprint, in the construction script use the “Get Map Size” to print the width. Then spawn this BP from the level BP on begin play event. Run it in PIE and it will report the correct width, run it in standalone and it reports a significantly lower number. In my case my maps are 10x10 and 8x5 but they all report as 4x4 in standalone.

Placing the BP in the level by hand instead of spawning it reports the correct size in PIE and standalone.

I tried to work bypass my need for the size so my game would stop crashing in standalone and once I was able to try it I ran into another bug where the maps weren’t rendering and were assigned the wrong name (all had the same name of one of my maps that they shouldn’t have been assigned to).

For anyone that has this problem, I have found a work around to use until its fixed. If you create a variable that is set to a class asset ID of the map you want to use then use that variable to set the tile map in the construction script everything works. This also seems to fix the tile maps not rendering bug.