Download

[Paper2D] Sprite gets stuck on the bottom of the screen

I have this setup:

93f858fe83.jpg

But when the Sprite reaches the bottom of the screen as seen here:

5d067bdfa076033806d32e1f0d4f4003169118fb.png

81ec63aee73ceaaaae889817c86c97458795d2fe.jpeg

I can no longer move at all. I am just stuck there. This doesn’t happen if I hit the top of the screen. Anyone got a clue?

How big is your file-size? Would you like help debugging it? What if you plug an obscene number into the Z for up?

How big is my file-size…?

If you zipped up your project, how big is it? If it is not to large, I wouldn’t mind giving it a quick look over. We did a similar style game for the Game Jam, and it sounds like you hit a similar snag.

I sent you a PM :slight_smile:

Oh wow. So I figured out what it was. When you come to the bottom of the Z axis, and you collide with something, it essentially is waiting for you to jump. By adding a jump node to the end of the “Up” function, I got it to work.

UNREAL DEVS: Is there a way to disable jump completely so this doesn’t happen with other projects?

b68c70aef00bca213f4ca20300ca0daa7c05127a.png

For your projectile, you need to set the velocity and speed, and tell the rotation to follow velocity.
Also, make sure to turn your sprite over if that’s what you want.

78cc11b37b34014610c8681534b2441945662318.png

That is…very odd… ._.
Do I actually have to jump at the end then? Or does it just fire the jump and you won’t notice it?

But I apply these things in the blueprint which worked just fine before. So doing that should not be necessary:

I didn’t notice any jumping, but it does get it away from, what basically, Unreal considers a floor. It’s not an ideal solution.

It also makes ascending again slower until you stop or descend before ascending again.
And not only that, if you ascend after the jump and you want to switch directions, the ship will stop until you release the directional key you were going in and press it again. Making it very clunky.

I will continue to play to see how this can be removed, or at least re-orient the gravity in another direction.

Thank you. This is really mind-boggling. Almost makes me want to just look into Unity 2D framework. The time and effort it takes to make something simple in UE4 seems unreasonable at the moment :c

What is your movement mode set to? If you guys are able to jump I’m assuming it is walking movement mode which also happens to include floor checks. What happens if you switch your default land movement to flying? This will disable gravity and floor checks.

I am suffering from a similar issue where when flying against a walkable surface my character gets stuck to the terrain, the issue being when my capsule touches the terrain it switches me back to walking mode

Okay I found a fix that doesn’t need to use the Jump hack-fix

I went into the Character Movement Component and found the two options:

dd0098341a93009732637dffe063a055cee452ce.png

Changing them to Flying fixed it. The movement can still be a little choppy at times but it’s minimal.

And now with these changes I can go back to this simple Bluescript (as I like to call it) instead of the unnecessary complex one:

23f46a838e.jpg

I just have to do a few changes to the Movement Component:

fa57b24303.png

Hah, I knew it. There is something with walking movement that causes you to stick to surfaces even with 0 friction. I made a video showing the issue

https://www.youtube.com/watch?v=edB8BNFdyDs

I guess I made a hack-fix for my projectiles dropping to -3500 Z for no reason whatsoever. But it’s not pretty.

c599e759effe27868357cc53961a88dca6e8b3fe.jpeg

I call this on my Projectile Blueprint.

As you can see, here is the issue and it makes no sense to me:

Take a look at my previous post for the projectile.

Not that I like to admit it (you won’t find a bigger Unreal fanboy) but it is mindbogglingly backwards and difficult to implement the simplest feature sometimes.

Your suggestion did not work. So I had to do something else.