Paper 2D Pixels are not square [SOLVED]

My pixels are not perfectly square when playing my Paper 2D game. Here are two images to show you my problem. (I have zoomed in to show you my problem (The green color is to show you where the pixels are displayed incorrectly, where color / texture is missing and should be))


Important information related to the game and camera:

  • I have a Monitor with a resolution of 1920 x 1080

  • The Camera Settings looks like this:


  • The Camera Boom Settings looks like this:

  • The Standalone Window (for testing the game) has the following resolution: (Multiple of 1920 x 1080)

Note: I have watched the video from Alan Noon at Epic Games on the Paper 2D setup:
Blueprint Creating a 2D Side-Scroller | 01 | Live Training | Unreal Engine - YouTube, Where he covers the setup for pixel perfect graphics. But on my end I seem to have some other problem.

Does anyone have a solution to my problem, or can point me in the right direction?
Thank you!

HAve you ensured that the Texture assets are not set to use Mipmaps or antialiasing?

Yes, I just checked. There is no antialiasing enabled and the texture assets show no difference with MipMaps enabled or disabled.

UPDATE: I did set the Camera Ortho Width to 380 instead of 384, and now all of the pixels seems to be fine. But it doesn’t make any sense. I will have to do some more testing… But, it looks good as of right now.

Update: I thought it worked at first, but now the model is stretched across one more pixel than it should.

Are your texture assets all power-of-two dimensions? I guess that only matters for compression but that reminds me, I wonder if the problem goes away if you turn off texture compression for those textures.

Update: Setting the Ortho Width to half of 384 (192) get’s rid of the problem, but it’s way to zoomed in.

Update: Rotating the camera -0.5 Degrees solves the problem and the character’s pixels look great. But the world is a bit skewed now…

Hm. That’s strange. They are constrained to a plane, right? XZ or YZ?

I have solved the problem. Please see my answer. Also thank you for your help. You made my head spin until I found the issue.

I solved the issue. My character is 9 pixels on the width. Stupid as I am, I placed the sprite in a location that was 0.5 in the Character Blueprint to center the collision, which resulted in the weird pixel offset on the sprite / flipbook.

Oh it was sitting on a sub-pixel!

Yepp… I really have no experience with Pixel Art or anything like that. But logically, you can’t split a pixel in half :wink: