Download

Pak File Loader Plugin

image_171995.png

Support thread for the Pak Loader plugin.

Allows you to mount .pak files through Blueprints and load assets.

Features

  • Mount/Unmount .pak files.
  • Register mount points to support references between pak assets.
  • Download (.pak) files via HTTP.
  • Load objects (all kind of assets).
  • Load classes (Blueprints).
  • Utility functions like GetMountedPakFilenames, GetFilesInPakDirectory, SHA1SUM, IsValidPakFile, etc.

Marketplace
https://www.unrealengine.com/marketp…-loader-plugin

Documentation (Read before buy)
https://drive.google.com/file/d/1DeS…AHs89rDUM/view

Example Project (Requires the plugin; read documenation first)
https://drive.google.com/file/d/1W6j…jiRkOrLIE/view

I just bought this and tested it, and was happy to see that BP_Test blueprint class was registered in the asset registry after download and mount. This was something I was struggling with for pak loading. I was going to try to make this work in a multiplayer game, and was wondering if you had tried this already? Would you have any reason to believe this wouldn’t work, or any suggestions as to how to make it work properly with multiplayer? Wondering best way to minimizing any kind of hitches in a VR game.

Well unfortunately it seems i still l cant get my own BP’s adding to the asset registry with this. Can a BP Asset not be added to the registry without a assetregistry.bin file?
Was trying to avoid using the plugin packaging method due to adding to the end user complexity, instead im running a cook with a CMD Editor then packaging the related assets but it always gives me this after mounting


LogStreaming: Error: Couldn't find file for package /Game/Avatars/New/BP_Bader requested by async loading code. NameToLoad: /Game/Avatars/New/BP_Bader
LogStreaming: Error: Found 0 dependent packages...
LogAssetRegistry: GetAssetsByPackageName for BP_Bader:    

@MagicBots
I don’t see a way how multiplayer would interfere with loading paks.

Do you mean asset loading hitches? Keep files small to keep loading times low.

@Rareden
I think there is way to scan asset paths with the asset registry node in Blueprints/C++.

Are you sure you are running this in a packaged build? Because it doesn’t work in “editor only”.

Yes its in a packaged game, tried shipping and development.
The plugin i was working on before you released yours is pretty much the same and i had the same issue. When i scan the pak content it registers all the non BP related assets into the registry just fine but it wont populate it with the BP’s even with the corrected file name e.g Path/Assetname.Assetname_C

FWIW I was having the same issue before this plugin too with registering mounted BPs… Thought it might be working here with that BP_Test that was loaded, but I haven’t had the chance to test pak’ing and mounting my own BPs with this yet. Will be great if that is working.

@Rareden
Have you tried loading the AssetRegistry.bin file with the function “LoadPakAssetRegistryFile”? Take a look at the documentation. PakLoaderPlugin.pdf - Google Drive
This one should populate all files.

Also, are you 100% sure about the path to the blueprint? Most of the time it’s just the path thing and Unreal can’t find it.
Can you show me the output of “UnrealPak.exe C:\YourPak.pak -List”. I can then tell you the correct RootPath and ContentPath for the RegisterMountPoint.

@MagicBots
Same here, please show me the output of the command from above. It can be really tricky to get this right.

Will test around today and see what I can find out.

Unrelated questions:
Wondering if there are any special considerations for mounting paks into my plugin, rather than main project content locations?

For mounting paks to my plugin, i’m wondering if i should download the .paks into the WindowsNoEditor/<ProjectName>/Content/Paks/ folder, or if I should make the folder: WindowsNoEditor/<ProjectName>/<PluginName>/Content/Paks/ …

I guess I will need to change the mountPath in the actual .pak file while pakking if i change the download location… but in general is it a better idea to just keep with <ProjectName>/Content/Paks location for downloading paks? So far I haven’t had the automatic pak loading work for me at all, and I’m not sure why. If the automatic pak loading did actually work from <ProjectName>/Content/Paks/ then i’d leave my pak downloads location there, but otherwise, i’m thinking it’ll be cleaner to move it under my plugins location and just create the appropriate folders. Does automatic pak mounting work for you? Is there any consideration for downloading paks to another locations such as my plugin location if i change the mountpaths during pak creation?

Are there other considerations other than making sure the mountPath is set to proper content location where it was originally pak’d from with the “Mount Pak File”, and that the rootpath and contentPath are also set to match to the plugin locations with the “Register Mount Point”?

Edit:
Answered my own question about pathing for plugin content by just trying it. Works fine, and in fact your example showed pathing for this. I still wonder about changing the location for the .paks to be in the plugin so it’s more self contained, and about automatic loading…

@BlueMountainsIO
Im manually cooking and pak’ing the necessary files rather than using the content plugin cooking method, so i dont get a .bin specifically for the assets, might try merging the .bin made after cooking manually though, if theres a way to merge them.

The path when i select the asset in the editor and copy reference is Blueprint’/Game/Avatars/New/BP_Bader.BP_Bader’
When i pak the files i remove the complete path (D:/ProjectName/Saved/cooked/) and replace /Content/ With /Game so it becomes /Game/Avatars/New

Image of the Pak List

[SPOILER]**[ATTACH=JSON]{“data-align”:“none”,“data-size”:“full”,“data-tempid”:“temp_172590_1568078737498_880”,“title”:“PakList.JPG”}[/ATTACH]
https://forums.unrealengine.com/core/image/gif;base64](https://forums.unrealengine.com/member/2347173-bluemountainsio)**​​[/SPOILER]

Im not too sure what to set the register mount point to with this method, ive been leaving it as this [SPOILER][ATTACH=JSON]{“data-align”:“none”,“data-size”:“full”,“data-tempid”:“temp_172591_1568078953637_141”,“title”:“Cap.JPG”}[/ATTACH]
https://forums.unrealengine.com/core/image/gif;base64
​​[/SPOILER]
Ive tried /Game as well. If i just use / as the root the registry adds the paths included in the pak to its cached paths as



[2019.09.10-01.27.05:922][787]LogBlueprintUserMessages: /Game/Avatars/New
[2019.09.10-01.27.05:923][787]LogBlueprintUserMessages: /Game/Avatars/New/Animations
[2019.09.10-01.27.05:923][787]LogBlueprintUserMessages: /Game/Avatars/New/Materials
[2019.09.10-01.27.05:924][787]LogBlueprintUserMessages: /Game/Avatars/New/Textures

Well I’m having the same problem as Rareden as I am also manually pak’ing the files. What creates the AssetRegistry.bin file, and is there a way to do it manually?

The AssetRegistry.bin is generated when you cook, not sure how you could cut out all but the required assets from it due to it containing more than just paths

For me the AssetRegistry.bin isn’t coming along to the packaged location. How does this normally get copied into the packaged location from the saved/cooked directory? I suppose it should be in the packaged location, otherwise how is it accessed at runtime? Maybe I’m missing a setting in my Project Launcher Custom Launch Profile? Sorry, first time learning about that AssetRegistry.bin so a little confused with why it’s not where I’d expect it to be.

Also my packaged location isn’t in the project dir. Is that expected for this to work? Otherwise, not sure how a path like the example path for the LoadPakAssetRegistry function would work. Example path provided: (…/…/…/TestProject/Plugins/TestDLC/AssetRegistry.bin).

I suppose a way it could work to have a minimal AssetRegistry.bin file would be to build it with a unreal session with only the contents you want inside… via a commandlet. That is if LoadPakAssetRegistry merges to the main asset registry?

Edit:
​​​​​​​
So I see that when I generate a patch for my content plugin i then have plugin specific AssetRegistry.bin in the cooked location for for the content plugin, but still not clear no standard process for getting that to come along for the ride at the packaged location.

This may be of some help about learning the .pak system and asset registry:

This was forked and updated from the original, it is a modding skeleton method. I think the assetregistry.bin for addon paks is also located and cooked inside of the .pak as well. I am not sure if that could cause a conflict. Using this .pak loader plugin along with the modskeleton method may help the process. The modskeleton allows adding .paks/mods without needing the original project at all…

Regardless it is a good learning tool along with the .pakloader plugin,

Thanks I saw this today and was playing with a different fork of it. Is this the latest and greatest?

I was playing with this one: GitHub - calben/ModSkeleton: Go-To Example for Unreal Engine 4 Modding Support
…and i saw they are just moving over their AssetRegistry.bin to the packaged location and associating with the plugin .pak file that way. Is that the standard practice?

I have also been trying to simply move in the packaged content plugin to the packaged game plugin location, with the cooked AssetRegistry.bin placed where @BlueMountainsIO plugin is expecting it according to the example. No success with having the registry successfully appended via the LoadPakAssetRegistry function thus far … Hoping @BlueMountainsIO can advise as to how that was working with his example which seems to also have the AssetRegistry.bin file being expected at a plugin location. Everything else is working, just not the registry…

Packaging my Content Plugin via Tom Looman’s Mod packaging example when trying the above…
https://www.tomlooman.com/add-mod-su…engine-4-game/

You would want to create a new folder because the FPaths::ProjectSavedDir()/Pak/ folder is mounted automatically by the engine.
This is what this plugin was made for to manually mount paks.
The location of the pak file on disk does not matter.

Glad the example helped you.

Unfortunately, the images you uploaded do not display.

By the way, from my testing, it’s not necessary to load the AssetRegistry.bin file manually. Just use the loading functions from this plugin and it will work.

Please show the output of the UnrealPak -List command. Also take a look at the documentaiton, the function LoadPakAssetRegistryFile is explained there. I would also suggest to try out the demo project.

By the way, from my testing, it’s not necessary to load the AssetRegistry.bin file manually. Just use the loading functions from this plugin and it will work.

@BlueMountainsIO Thats weird, Attached the images instead
Is the …/…/…/ before the mount point important?

It is working to spawn my assets. They are downloading and mounting fine. The static meshes are only showing up in the asset registery only after being spawned once howerver, and BP’s I can’t register with assetRegistry yet.

Here’s an output of my UnrealPak.exe -List for an example asset:

LogPakFile: Display: Using command line for crypto configuration
LogPakFile: Display: Added 0 entries to add to pak file.
LogPakFile: Display: Mount point …/…/…/Pod/Plugins/ModPlugin/Content/DLC/13034129-7933-4fb8-86a0-8fb876d20c72/
LogPakFile: Display: “Cube.uasset” offset: 0, size: 1228 bytes, sha1: AEE2E38AACAA4C47A5E9E0F04EE6C20235235A1F, compression: Zlib.
LogPakFile: Display: “Cube.uexp” offset: 1298, size: 2326 bytes, sha1: D5D6A206484825737425B2A2E88018959C2167AF, compression: Zlib.
LogPakFile: Display: “M_Cube.uasset” offset: 3694, size: 504 bytes, sha1: 19929E4F09BCF08ECBF8FDA1927BE1E1A4B29AB3, compression: Zlib.
LogPakFile: Display: “M_Cube.uexp” offset: 4268, size: 43501 bytes, sha1: F68F832E786E47CBB837FCEDC41066881636B344, compression: Zlib.
LogPakFile: Display: 4 files (47559 bytes), (0 filtered bytes).
LogPakFile: Display: Unreal pak executed in 0.005045 seconds

@Cytokinetik. This is great example and just what I needed for knowing what I was missing in terms of building a mod, however, it isn’t a working example for me on 4.22 unfortunately. Only the ‘cooked’ directory gets made for the content plugin during build, and not the ‘StagedBuild’ directory which is of course needed for this command that copies the pak file from the plugin ‘StagedBuild’ to the mod directory:

copy /Y .\Plugins\ModSkeletonExamplePluginA\Saved\StagedBuilds\WindowsNoEditor\ModSkeleton\Plugins\ModSkeletonExamplePluginA\Content\Paks\WindowsNoEditor\ModSkeletonExamplePluginA.pak .\Mods\ModSkeletonExamplePluginA.pak

I’m not sure how to fix it to make cooking not fail, and packaging to make the StageBuild. The cook command fails half way through, which they say is fine, but clearly is not. Would you know if there is a newer working example for 4.22?

I need to fork/update repo the correct way still, but here is ModSkeleton for 4.22:

If you setup the 2 package profiles correctly it should work, I changed the .bat file because it did not have the correct filename to copy the .pak properly.
Cooking should not fail, only gives warnings because it thinks it needs those references but it does not. You should also be able to access the AssetRegistry from within the modpak at runtime with the PakLoader plugin…