.pak encryption missing in Project Launcher

The new .pak encryption options are missing in the Project Launcher. There also exists no encryption.ini or information on how to create one to set up the encryption key.

I was able to find it by search for encrypted on Project Settings, but I can’t find the Encryption.ini too.

The packaging settings within Project Settings does not apply or are overridden by the Project Launcher, for example, the nativization needs a -nativize tag in the Project Launcher, regardless if you have the Project Settings for it or not, aswell as the option to encrypt ini files which are present both in Project Settings and the Project Launcher. To my understanding you would need to input some command into the Project Launcher or have a checker box for that feature.

I’ve done multiple attempts at getting encryption to work, but nothing is happening…

“LogPakFile:Display: 35 files requested encryption, but no AES key was supplied! Encryption was skipped for these files”

I’ve added the key to the game.build.cs files, created an encryption.ini with the key in in the config folder, dosen’t even matter if I hard code the AES key into the engine, nothing…

Any advice is appreciated, ive explored multiple ways of setting up the Encryption.ini but nothing is working.

By random luck I came across this note in the release notes for UE4.15:

“Both AES encryption and pak signing are now configured from an Encryption.ini config hierarchy. See Config\DefaultEncryption.ini and Config\Windows\WindowsEncryption.ini in the ShooterGame sample project for an example of how to configure both encryption and pak signing.”

My first test using this seems successful. If any one have any good advice on generating the 3 RSA keys I’d appreciate any help on this, but the AES part is easy to handle. \o/


edit: Note, this also works from the project launcher.

I think this will work, AES Keys: https://asecuritysite.com/encryption/keygen, RSA Key: Online RSA Key Generator

Still nothing… I trying something stuff too, if I have something new I update here.

Still no news on this, its very frustrating at this point. No one at all knows how to set this up?

I’m trying this as well. Downloaded the free ShooterGame sample and used the DefaultEncryption.ini and WindowsEncryption.ini from that project.
The DefaultEncryption.ini includes the keys, so if this file is missing then the compiler will complain that I didn’t provide any AES keys, so the files will not be encrypted.

In the Project Settings / Packaging part I have both enabled: Encrypt ini files and Encrypt pak index.

Now the encryption seems to be triggering during packaging, but it fails with an ERROR: AutomationTool terminated with exception: AutomationTool.AutomationException: Stage Failed. Missing receipt…
PackagingResults:Error: Error Missing UE4Game binary.You may have to build the UE4 project with your IDE. Alternatively, build using UnrealBuildTool with the commandline:UE4Game

How did you overcome this problem?
Is there any other place where I need to set something up?

Same error with 4.18