Packing failed because of AdminAccess -> AdminUser

Hey I upgraded a Project from 4.10 to 4.11 a while ago, because of some struct issues in 4.10. Now I tried to test it on the mobile device and I get an building error. I have no clue why and what the issue is. The folder that is created becomes unwritable and I cant even delete it. Im logged in as an AdminUser The build itself seems to be okay but it cant be written on the drive, my gues. This is the end of the log after the build successful message, mb someone has an idea.

MainFrameActions: Packaging (Android (All)): BUILD SUCCESSFUL
MainFrameActions: Packaging (Android (All)): Total time: 31 seconds
MainFrameActions: Packaging (Android (All)): Program.Main: ERROR: AutomationTool terminated with exception: System.UnauthorizedAccessException: Der Zugriff auf den Pfad "D:\UnrealProjectsWorkspace\InfinityMonsterQuest\Binaries\Android\InfinityMonsterQuest-armv7-es2.apk" wurde verweigert.
MainFrameActions: Packaging (Android (All)):    bei Syst
MainFrameActions: Packaging (Android (All)): em.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
MainFrameActions: Packaging (Android (All)):    bei System.IO.File.InternalCopy(String sourceFileName, String destFileName, Boolean overwrite, Boolean checkHost)
MainFrameActions: Packaging (Android (All)):    bei UnrealBuildTool.UEDeployAndroid.MakeApk(AndroidToolChain ToolChain, String ProjectName, String ProjectDirectory, String OutputPath, String EngineDirectory, Boolean bForDistribution, String CookFlavor, Boolean bMakeSeparateApks, Boolean bIncrementalPackage, Boolean bDisallowPackagingDataInApk)
MainFrameActions: Packaging (Android (All)):    bei UnrealBuildTool.UEDeployAndroid.PrepForUATPackageOrDeploy(FileReference ProjectFile, String ProjectName, String ProjectDirectory, String ExecutablePath, String EngineDirectory, Boolean bForDistribution, String CookFlavor, Boolean bIsDataDeploy)
MainFrameActions: Packaging (Android (All)):    bei AndroidPlatform.Package(ProjectParams Params, DeploymentContext SC, Int32 WorkingCL)
MainFrameActions: Packaging (Android (All)):    bei Project.Package(ProjectParams Params, Int32 WorkingCL)
MainFrameActions: Packaging (Android (All)):    bei BuildCookRun.DoBuildCookRun(ProjectParams Params)
MainFrameActions: Packaging (Android (All)):    bei AutomationTool.BuildCommand.Execute()
MainFrameActions: Packaging (Android (All)):    bei AutomationTool.Automation.Execute(List`1 CommandsToExecute, CaselessDictionary`1 Commands)
MainFrameActions: Packaging (Android (All)):    bei AutomationTool.Automation.Process(String[] CommandLine)
MainFrameActions: Packaging (Android (All)):    bei AutomationTool.Program.MainProc(Object Param)
MainFrameActions: Packaging (Android (All)):    bei AutomationTool.InternalUtils.RunSingleInstance(Func`2 Main, Object Param)
MainFrameActions: Packaging (Android (All)):    bei AutomationTool.Program.Main()
MainFrameActions: Packaging (Android (All)): Program.Main: AutomationTool exiting with ExitCode=1 (Error_Unknown)
MainFrameActions: Packaging (Android (All)): Domain_ProcessExit
MainFrameActions: Packaging (Android (All)): copying UAT log files...
MainFrameActions: Packaging (Android (All)): BUILD FAILED
PackagingResults:Error: Error Unknown Error

Hey Sudikinoko,

We are having some trouble reproducing this here. Are you packaging from the file menu or the frontend? Also, are you picking the binaries folder as your location when you decide to package? I understand that it creates a duplicate in that folder and that could be the problem, but if you’re choosing it as your build folder, then there could be a conflict.


Hey Williams,

I hope i can provide some usefull information.
I use perforce as Source Control. Under the --packaging-- tap i choose a complete different path then the project itself as the location for the Staging Directory, I did not change anything else yet.

I package the build via file menu with this error log, also tried to launch it directly to the mobile device, get an error too.

The same project could be build in 4.10 without problems. The changes are the Source Control and 4.11 and more BPs. My VS version is 2013 community and the android SDK is the one from 4.10. I reinstalled the Android SDK with the one from the 4.11 version and installed VS2015C, but it is still not working. UE4 ignores VS2015 on my side.

Can you try removing the apk found here from your workspace: D:\UnrealProjectsWorkspace\InfinityMonsterQuest\Binaries\Android\

In the meantime, you can try unchecking the read only flag on the file to see if it resolves the issue.

If this is part of your P4 workspace, then it is read only. I don’t believe the editor expects this file to be read only as it is generally not part of a depot.


Omg, thank you. Deleting the apk inside the binary was the solution. I really appretiate it, would never get the idea.

Edit: Tried a few times to compile and build everything, the new apk in the binaries folder does not trigger this error.

Just FYI, P4 makes all it’s files read only when sync’d. Because that APK is typically not included in the P4 Sync, then engine doesn’t expect the file to be read only.