Packed project doesn't load proper level, but viewport does

Hi, so muh project have main menu with start button wich leads to level named “Level03”
If i run game through viewport or standalone mode everything works as intended
But when i packeg project and press start button though it, it begins to lead to next level after Level03, just skipping it

1 Like

Hi! Check the Project Setting → Maps & Modes and set Game Default Map to your MainMenu level

And also check Project Setting → Packaging → List of maps to include in packaged build

i don’t know how, but nothing of this works
still opens next level
just nonsence

Sorry, I thought the problem was with a starting level in packaged game.
MainMeny Start button should open Level03 instead of Level04_diner, right?
Try to open Level03 in a packaged game through the console Open Level03? so we could test that it’s present in the build and opens correctly

Thanks for reply, but i just found answer
Problem was obvious, but it just collision component of portal to next level there not casted through playercharacter so any object overlaped him
It’s wierd that i found this problem only now cause i worked on this project for months already and everything worked alright most of the time

1 Like