Packed game icon doesn't show

When I package my game my icon does show up in windows explorer but when I start the game the game gets the UE icon back in the toolbar.

Hey Enrico,

Are you packaging for Windows? If so, we have a bug in for this listed as UE-1419. It’s currently unresolved and does not have an estimated fix version. If this is not a Windows issue on your end, please provide further details so that we can investigate this further.


It was a Windows issue, thanks for the response! :slight_smile:

Any updates?

Hey ,

This issue is still in as unresolved, it’s currently set at a priority ‘3’ which is normal. More pressing issues, such as crashes will be handled before this one.


Has this been fixed yet? :confused:

UE-1419 has not yet been corrected. There is not a fixed version set on the bug either.

This is a thing that every game should have, I don’t get why it’s taking so long…

I found a way to circumvent this issue.
Do this at your own risk because it’s not safe way.
I googled “exe change icon” then found article about ResourceHacker.
Then I applied that to my exe file. But nothing changed.
After a while, I realized and applied the method to
And it worked as I expected. Now I can avoid amaturish looks.
(I don’t know if UE4PrereqSetup_x64.exe needs it too.)

Hey is it fixed in 4.11?

According to , this bug is still backlogged. But there is a way to fix the issue on your own in the meantime, which has been posted in this thread by ChichigeBobo.

Sad, UE4.21.0, but still not fix it…

still not fixed 4.21.2