Packed game can't find dll (only on one maschine)

Hey guys

In my project I am using a third party library to implement MQTT which worked fine up to this point.

I added Include and Library paths to the Build.cs file and used the library in my C++ files without any problems.

Now when I package the game and want to start it, an error pops up because it can’t find the coresponding dll (paho-mqtt3a.dll). I found the dll in the Binaries folder of the project and copied it in the working directory of the packed game and now everything works fine… at least on most machines.

On one pc I still get the error message that the dll is missing although it’s right there in the same directory. The oddest thing is that usually when a dll is missing the game won’t even start and the error message pops up instantly.
But in this case the game starts and I get a black screen for 10-15 second until the error message shows up.

Has anyone else experienced such behavior?
And is copying the dll from the Binariy folder normal procedure or should I do this in a different way?

Hi, I’m trying to do this implementation with mqtt, but I have not yet succeeded. Can you tell me where to get this code?