PackagingResults:Error: Error Unknown Cook Failure

Not entirely sure what’s going on here when I tried to package my scene.

Here’s the output log up to the point where I start the package. I was packaging for Windows 64-bit and no other platform.

LogSavePackage: Save=1696.36ms
LogSavePackage: Moving ‘…/…/…/…/…/…/Unreal Projects/Corridor 4.13/Saved/UEDPCCorridor-07-IntLight_Redux63FA65184475FD99F70B6DA9EA13291C.tmp’ to ‘…/…/…/…/…/…/Unreal Projects/Corridor 4.13/Saved/Autosaves/Game/Maps/UEDPCCorridor-07-IntLight_Redux.umap’
LogSavePackage:Display: Finished SavePackage …/…/…/…/…/…/Unreal Projects/Corridor 4.13/Saved/Autosaves/Game/Maps/UEDPCCorridor-07-IntLight_Redux.umap
LogEditorTransaction: Undo Spawn Play From Here Start
UATHelper: Packaging (Windows (64-bit)): Running AutomationTool…
UATHelper: Packaging (Windows (64-bit)): Automation.ParseCommandLine: Parsing command line: -ScriptsForProject=“J:/Unreal Projects/Corridor 4.13/Corridor.uproject” BuildCookRun -nocompile -nocompileeditor -installed -nop4 -project=“J:/Unreal Projects/Corridor 4.13/Corridor.uproject” -cook -stage -archive -archivedirectory=D:/TEST -package -clientconfig=Devel
opment -ue4exe=UE4Editor-Cmd.exe -pak -prereqs -nodebuginfo -targetplatform=Win64 -CrashReporter -utf8output
UATHelper: Packaging (Windows (64-bit)): Automation.Process: Setting up command environment.
UATHelper: Packaging (Windows (64-bit)): WindowsPlatform.get_Compiler: WARNING: Visual C++ 2015 toolchain does not appear to be correctly installed. Please verify that “Common Tools for Visual C++ 2015” was selected when installing Visual Studio 2015.
UATHelper: Packaging (Windows (64-bit)): BuildCookRun.SetupParams: Setting up ProjectParams for J:\Unreal Projects\Corridor 4.13\Corridor.uproject
UATHelper: Packaging (Windows (64-bit)): Project.Cook: ********** COOK COMMAND STARTED **********
UATHelper: Packaging (Windows (64-bit)): CommandUtils.RunCommandlet: Running UE4Editor Cook for project J:\Unreal Projects\Corridor 4.13\Corridor.uproject
UATHelper: Packaging (Windows (64-bit)): CommandUtils.RunCommandlet: Commandlet log file is J:\Program Files (x86)\Epic Games\4.13\Engine\Programs\AutomationTool\Saved\Cook-2016.11.06-15.51.36.txt
UATHelper: Packaging (Windows (64-bit)): CommandUtils.Run: Run: J:\Program Files (x86)\Epic Games\4.13\Engine\Binaries\Win64\UE4Editor-Cmd.exe “J:\Unreal Projects\Corridor 4.13\Corridor.uproject” -run=Cook -TargetPlatform=WindowsNoEditor -fileopenlog -unversioned -abslog=“J:\Program Files (x86)
UATHelper: Packaging (Windows (64-bit)): Epic Games\4.13\Engine\Programs\AutomationTool\Saved\Cook-2016.11.06-15.51.36.txt” -stdout -FORCELOGFLUSH -CrashForUAT -unattended -UTF8Output
UATHelper: Packaging (Windows (64-bit)): UE4Editor-Cmd:
UATHelper: Packaging (Windows (64-bit)): UE4Editor-Cmd: LogInit:Display: Running engine for game: Corridor
UATHelper: Packaging (Windows (64-bit)): UE4Editor-Cmd: LogInit:Display: RandInit(-103721168) SRandInit(-103721168).
UATHelper: Packaging (Windows (64-bit)): UE4Editor-Cmd: LogPluginManager:Error: This project requires the ‘Substance’ plugin. Install it and try again, or remove it from the project’s required plugin list.
UATHelper: Packaging (Windows (64-bit)): CommandUtils.Run: Run: Took 0.4806984s to run UE4Editor-Cmd.exe, ExitCode=1
UATHelper: Packaging (Windows (64-bit)): Project.Cook: Cook failed. Deleting cooked data.
UATHelper: Packaging (Windows (64-bit)): Program.Main: ERROR: AutomationTool terminated with exception: AutomationTool.AutomationException: Cook failed. —> AutomationTool.AutomationException: BUILD FAILED: Failed while running Cook for J:\Unreal Projects\Corridor 4.13\Corridor.uproject; see log C:\Users\CK\AppData\Roaming\Unreal Engine\AutomationTool\Logs
UATHelper: Packaging (Windows (64-bit)): at AutomationTool.CommandUtils.RunCommandlet(FileReference ProjectName, String UE4Exe, String Commandlet, String Parameters)
UATHelper: Packaging (Windows (64-bit)): at AutomationTool.CommandUtils.CookCommandlet(FileReference ProjectName, String UE4Exe, String[] Maps, String[] Dirs, String InternationalizationPreset, String[] CulturesToCook, String TargetPlatform, String Parameters)
UATHelper: Packaging (Windows (64-bit)): at Project.Cook(ProjectParams Params)
UATHelper: Packaging (Windows (64-bit)): — End of inner exception stack trace —
UATHelper: Packaging (Windows (64-bit)): at Project.Cook(ProjectParams Params)
UATHelper: Packaging (Windows (64-bit)): at BuildCookRun.DoBuildCookRun(ProjectParams Params)
UATHelper: Packaging (Windows (64-bit)): at AutomationTool.BuildCommand.Execute()
UATHelper: Packaging (Windows (64-bit)): at AutomationTool.Automation.Execute(List1 CommandsToExecute, CaselessDictionary1 Commands)
UATHelper: Packaging (Windows (64-bit)): at AutomationTool.Automation.Process(String[] Arguments)
UATHelper: Packaging (Windows (64-bit)): at AutomationTool.Program.MainProc(Object Param)
UATHelper: Packaging (Windows (64-bit)): at AutomationTool.InternalUtils.RunSingleInstance(Func`2 Main, Object Param)
UATHelper: Packaging (Windows (64-bit)): at AutomationTool.Program.Main()
UATHelper: Packaging (Windows (64-bit)): Program.Main: AutomationTool exiting with ExitCode=25 (Error_UnknownCookFailure)
UATHelper: Packaging (Windows (64-bit)): BUILD FAILED
PackagingResults:Error: Error Unknown Cook Failure

I goofed and didn’t think a text doc would’ve been nicer to post. link text

Hey there,

Recently dealt with this one :slight_smile:

Open the file located below or maybe the UAT log that is also in that folder and do a search for ":error’.
Go through all the errors and fixed them up, in my case I was getting an error in AnimSequence.cpp, and it was because the AnimationSequence reference right above the error didn’t have a valid skeleton. In that case I either double clicked the animation and set the skeleton or deleted the file.

C:\Users\CK\AppData\Roaming\Unreal Engine\AutomationTool\Logs\ J+Program+Files+(x86)+Epic+Games+4.13\Cook-2016.11.06-15.51.36.txt


I tried this and found this:

UATHelper: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2016.11.08-02.07.09:390][ 0]LogPackageName:Error: DoesPackageExist: DoesPackageExist FAILED: ‘/Game/Materials - Backup/WallArt_MAT’ is not a standard unreal filename or a long path name. Reason: Name may not contain the following characters:

Not entirely sure as to how it’s finding these errors since I don’t have spaces in my naming conventions. :confused:

Jeez… I can’t believe I made a folder with spaces. -_- It was just an empty folder. I think I made it when I was copying and moving around materials. Jeez. I’m so mad at myself. It worked after I deleted the folder and packaged it again.

Thanks a bunch! I’ll definitely use the :Error search method to nail down what errors I’m specifically getting next time!!