PackagingResults:Error: Error Launch failed! Unknown Error

I’m trying to test my game on my Android device (Galaxy S6), but every time I try to deploy it, I get this error. I get the same result with the default first person project, so I’m thinking I don’t have my SDK setup properly. I have followed the quick start guide and searched online but haven’t had any luck. Is there something specific I should look at?

LogPlayLevel: C:\\android-sdk-windows\tools\ant\build.xml:720: The following error occurred while executing this line:
LogPlayLevel: C:\\android-sdk-windows\tools\ant\build.xml:734: Compile failed; see the compiler error output for details.
LogPlayLevel: Total time: 11 seconds
LogPlayLevel: BuildCommand.Execute: ERROR: BUILD FAILED
LogPlayLevel: Program.Main: ERROR: AutomationTool terminated with exception:
LogPlayLevel: Program.Main: ERROR: Exception in UnrealBuildTool: ERROR: cmd.exe failed with args /c "C:\\apache-ant-1.8.2/bin/ant.bat" debug
LogPlayLevel: Stacktrace:    at UnrealBuildTool.Android.UEDeployAndroid.RunCommandLineProgramAndThrowOnError(String WorkingDirectory, String Command, String Params, String OverrideDesc, Boolean bUseShellExecute)
LogPlayLevel:    at UnrealBuildTool.Android.UEDeployAndroid.MakeApk(String ProjectName, String ProjectDirectory, String OutputPath, String EngineDirectory, Boolean bForDistribution, String CookFlavor, Boolean bMakeSeparateApks, Boolean bIncrementalPackage, Boolean bDisallowPackagingDataInApk)
LogPlayLevel:    at UnrealBuildTool.Android.UEDeployAndroid.PrepForUATPackageOrDeploy(String ProjectName, String ProjectDirectory, String ExecutablePath, String EngineDirectory, Boolean bForDistribution, String CookFlavor, Boolean bIsDataDeploy)
LogPlayLevel:    at AndroidPlatform.Deploy(ProjectParams Params, DeploymentContext SC)
LogPlayLevel:    at Project.Deploy(ProjectParams Params)
LogPlayLevel:    at BuildCookRun.DoBuildCookRun(ProjectParams Params)
LogPlayLevel:    at BuildCommand.Execute()
LogPlayLevel:    at AutomationTool.Automation.Execute(List`1 CommandsToExecute, CaselessDictionary`1 Commands)
LogPlayLevel:    at AutomationTool.Automation.Process(String[] CommandLine)
LogPlayLevel:    at AutomationTool.Program.MainProc(Object Param)
LogPlayLevel:    at AutomationTool.InternalUtils.RunSingleInstance(Action`1 Main, Object Param)
LogPlayLevel:    at AutomationTool.Program.Main()
LogPlayLevel: ProcessManager.KillAll: Trying to kill 0 spawned processes.
LogPlayLevel: Program.Main: AutomationTool exiting with ExitCode=Error_Unknown
LogPlayLevel: Domain_ProcessExit
LogPlayLevel: copying UAT log files...
LogPlayLevel: RunUAT.bat ERROR: AutomationTool was unable to run successfully.
LogPlayLevel: Completed Launch On Stage: Deploy Task, Time: 23.428317
PackagingResults:Error: Error Launch failed! Unknown Error

Hello -

Are you packaging from a Github version of the engine or from a Launcher version of the engine and are the projects C++ based or Blueprint Based?

Thank You


Hi ,
The project is blueprint based, and I believe it is the launcher version of the editor, as in I start the editor from the unreal launcher. Thanks for looking into this!

Would you mind taking a screenshot of your Packaging settings specifically the Android and Android SDK sections (feel free to redact any developer specific settings)?


Now that I look at it, there are a lot of blank fields… It looks like they have a default value if they aren’t assigned a specific one though…

Hello -

I am fairly certain that all you will need to do is input the directories into your Android SDK based on where your SDK is installed on your PC. Let me know if you are still having issues afterwards.


Thanks! Set everything to the C: directory and went to test, but I can’t get the unreal engine to detect my phone now! So frustrating! Phone had dev mode, USB debugging turned on. I have tried in MTP and PTP modes. adb detects the device. I have restarted my computer and phone. nothing… I’m pulling my hair out!

Hi -

Are you getting a Device ID when you run the command adb devices in the Command Line? If not let me know -


Yes I am. I started another question specific to this on this here:

I have also tried upgrading to 4.10 but that didn’t change anything…

Hey -

I answered your other question at the linked Answerhub post, but to clarify here as well, it looks like some Environment Variables need to be set, I have posted the link at your other question.


Thanks , that got the other problem solved! But now I’m back to the exact same old problem! Here is a picture of the Android SDK menu… Did I do it wrong or something? This is very frustrating, but I appreciate you helping me through it!



Hi -

Try setting your SDK API Level in the Android SDK section to matchndk and see if it will package for you.

YES!!! Finally worked! Thanks so much for helping with this!

I’m having this problem as well but for Windows… could you help? haha


Please submit your own question to AnswerHub along with and we’ll look into the problem further for you.


Good day! Always appears this error and as I can not to resolve it, could you please help me. The screenshots are attached. Thanks in advance!Good day! Always appears this error and as I can not to resolve it, could you please help me. The screensh

ots are attached. Thanks in advance!

Please submit your own AnswerHub thread for additional assistance. Your issue may differ from the one above and we like to keep one issue per thread.