PackagingResults: Error: Error Launch failed! Missing UE4 Game binary

Hey guys,

I’m just a silly artist with very little (no?) understanding of ‘under-the-hood’ issues. I’ve looked for an answer to this - and while I have found discussions about it - the solutions lack the detail for me to actually understand the fix.


PackagingResults:Error: Error Launch failed! Missing UE4Game binary.
You may have to build the UE4 project with your IDE. Alternatively, build using UnrealBuildTool with the commandline:
UE4Game <Platform> <Configuration>

That is the error I get when trying to launch my game. I really need a step-by-step. I don’t even know what a GitHub is :confused:

Dodges the flying rotten tomatoes

It looks like the game has not been built, Try clicking the “Compile” button on the main UE4 tool strip.
This is odd because the editor rebuilds the code for me each time I package the gate, Unless launching uses different logic.

HTH

Hmmm, I’m not seeing a ‘Compile’ button anywhere…

That may only show for C++ projects, Have you tried using the “Package” option ?
The package option causes all (relevant) items to be compiled and placed in the specified directory for me.

HTH

just in case someone has this issue, go to packaging setting and set build to ‘Always’.

2 Likes

I’ve tried the solutions above, but have had no luck. Below is the error I’m getting when I try and launch my project.

LogPlayLevel: Error: ERROR: Stage Failed. Missing receipt ‘D:\UE4\Unreal-Projects\VrTest\Binaries\Android\VrTest.target’. Check that this target has been built.
LogPlayLevel: (see C:\Users\Brett\AppData\Roaming\Unreal Engine\AutomationTool\Logs\D+UE4+UE_4.22\Log.txt for full exception trace)
LogPlayLevel: Completed Launch On Stage: Build Task, Time: 0.754044
LogPlayLevel: AutomationTool exiting with ExitCode=103 (Error_MissingExecutable)
LogPlayLevel: Completed Launch On Stage: Deploy Task, Time: 0.000043
LogPlayLevel: BUILD FAILED
PackagingResults: Error: Launch failed! Missing UE4Game binary.
You may have to build the UE4 project with your IDE. Alternatively, build using UnrealBuildTool with the commandline:
UE4Game <Platform> <Configuration>

You need to install the Visual Studio. That problem occures because you have C++ classes in your project and no IDE to compile them.

Hi everyone, I am new here and would like to here your thoughts/approaches about an issue I currently have. So, I am working in Bootcamp, Unreal Engine 4.24.3 in combination with an Oculus Quest headset. My current problem occurs when I launch the project to the headset. According to the Output Log that stops the launch process: LogPlayLevel:* Error: ERROR: Stage Failed. Missing receipt ‘C:… .target’. Check that this target has been built. *

As well as: PackagingResults: Error: Launch failed! Missing UE4Game binary.
You may have to build the UE4 project with your IDE. Alternatively, build using UnrealBuildTool with the commandline:
UE4Game <Platform> <Configuration>

I already googled these problems and found different approaches such as adjust packaging settings (packed my project already - didn’t help), changing settings (like above mentioned ‘Always’ - didn’t help), adjust the project settings (didn’t help), Android SDK: naming specificly the directory (didn’t help). Anymore ideas? I kind of loosing hope :frowning: to solve this problem.

Many thanks in advance!

Hi guys. I got a similar error when compiling and launching my level. I noticed that I had previously installed a new “substance plugin”. After disabling it, the error disappeared. I specifically checked this on versions 4.24.3 and 4.25.3, I will be glad if it helps You.

Hi all, I ran into this same problem when I first started (uh, yesterday!).

The step I was missing was to go to File > Package Project, and choose the platform you’re working with. In my case, it is Android, so I selected "Android (Multi,DXT,ETC2). Then, I was prompted to save, and I chose my project folder root to save in. In my case, I selected **Documents/Unreal Projects/**project-name. This should match the path in your .target error, before the path segment /Binaries.

After this finished processing (took a while), I saved my project and pressed Launch (to my Android device). It was successful, with no .target or UE4Game binary errors.

Looking into my project root folder, I can see the new Binaries folder with the target file.

7 Likes

you just have to select the IDE you are using to encode