Download

Packaging Wont Work

Whenever I try to package my project in windows 64bit in engine version 4.23 it creates a new tab in my browser of the ue4 documentation page. How can I fix this, Thanks.

The window it opens: https://docs.unrealengine.com/en-US/Engine/Tutorial/Installation/InstallingVisualStudioTutorial.InstallingVisualStudioTutorial/index.html

thats not relevant to the question.
**literaly clicking on the "**File > Package Project > [PlatformName]" button does nothing in this instance and opens the docs main page when it should refer to the visual studio install page.
OP do you have visual studio installed? (community 2019) sometimes that pages opens when the toolchcains are missing that are required to package.

Unreal Engine still uses VS 2017 by default, but also supports VS 2019

this is the link that should open but doesn’t

hi me too i have the same problem, im tryng to understand what’s the problem, i have installed 4.24.1 with android flagged in UE install option, VS community 2017 with C++
im tryng also to understand if my android option in UE install setup is the same that nvidia android work setup file which is located in the sub engine folder, because i have tried to run it and nothing happen

SOLVED: Install Visual studio community ( www.visualstudio.com/download/) with C++ package content checked and restart. Is a Substance plugin issue.

Thank you so much, moved to new OS a while ago and since then only worked on the project but never packaged it. So had the same error that just the plain website opened and installing visual studio solved it. Would have taken me soooo much longer to find that out ty! :slight_smile:

I installed Visual studio community and it has definitely NOT solved the problem for me.I have only just starting using UE4 but without packaging it is useless.

I have zhe same problem

1 Like

I had the same issue too. but I set the “Staging Directory” in the Project Settings->Project - Packaging->Project.
I also set the Build Configuration to “Shipping”

I hope it helps someone.

Hellooooooooooooooooooooooo everyone…Finally I found the real solution for this … the problem is your NDK is old and you have to download another newer one …that is it ooooooowwwwwww yeaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaah

2 Likes

i tried almost all the solutions given on this page but nothing solved it… any other ideas?

should i just uninstall unreal engine and install it again?