Packaging with for Distribution Fails

Hello everybody,

my problem is, when i package my android project, with “for distribution” selected, it will fail. without there is no problem.
But to upload my apk to the playstore it must be “for distribution”.

My Log: link text

What i already tried:

I have set my keystore correctly and i already tried to reinstall the android sdk and unreal engine itself.

but nothing worked for me.

Please help!

Try this


thanks for your answer. I tried it like you did, but it still wont work.

Is there any other way to fix this?

With Gradle you need to have the Android Support Repository and Android Support Library

I was having problems with packaging too, but I realized that I was missing a repository. After having a look at the logs your issue seems the same.

This solved my issue with failed packaging - >

Go to - NVPACK\android-sdk-windows\tools\android.bat

Downloaded/Update Android Support Repository and Android Support Library

It should be at the bottom

Other things to try in case above fails(which it should not)

If you are packaging with a C++ or nativization enabled project. Make sure you have Visual Studio Community 2017 well set up

If not try packaging a blank blueprint project and see if it successfully packages. If yes, then it is some project specific issue.

According to this line

UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): FAILURE: Build failed with an exception.
UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): * What went wrong:
UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): A problem occurred configuring project ':app'.
UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): > Could not resolve all dependencies for configuration ':app:_debugApk'.
UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)):    > A problem occurred configuring project ':permission_library'.
UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)):       > You have not accepted the license agreements of the following SDK components:
UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): [Android Support Repository].
UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): Before building your project, you need to accept the license agreements and complete the installation of the missing components using the Android Studio SDK Manager.
UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): Alternatively, to learn how to transfer the license agreements from one workstation to another, go to
UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): * Try:
UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

I think it will solve your issue

I Love you man, now it works.