Download

Packaging loads wrong map, but config seems fine. Please help!!

Hello! Rare of me to post; this issue is kind of above me.

I have a simple game with an L_Blank map (set to be default) and an L_Main which is the one that’s supposed to be loaded when you create a session. You do this by pressing “Host” button at L_Blank.

It’s key that it works this way so that the other device can press the “Join” button at L_Blank and join the other player’s session.

This is the Maps&Modes config at the engine:

And this is the DefaulEngine.ini at the project Config folder:

config.jpg

Nevertheless, it loads straight to L_Main when opening the game in an Android. It used to work properly at some point before, and I did no weird changes to configs or anything in between. It just stopped working like it should.

I even tried the “Cook everything inside project content directory (ignore list of maps below)” but it still fixes nothing.
Is there anything else I missed? If it does anything, I am packaging while having L_Blank loaded but I think that only matters for launching.

It works properly in the Windows build (it starts at L_Blank), but not on the phone one.

Instant edit, forgot to add: for the ones that are familiar with this issue, L_Main used to be the default map when I created the project. Maybe that’s a hint. I could essentially shift the session UI to L_Main so that it loads there and then create yet another map to play at, but seems like a reeeeeally dumb workaround and losing control like that sets my yellow alarms on. Thanks in advance!

please share code that host button calls.

Nothing wrong with buttons, I explained that the issue is that the map that’s supposed to be loaded when you first boot up the game in mobile is not the same than in pc.

Have you added any maps to cook? Maybe you missed that map

Thanks for your reply!

If I did or did not do that already, wouldn’t it be consistent in Windows AND mobile? And yeah I basically tried all the permutations between those options, like adding the maps manually, telling it to cook everything, etc.

This is not a showstopper in THIS particular case for me, but it seems like a dumb bug to have to get around of.
OR there are some references that got screwed up somehow and I’d like to know how to go and fix it

Looks like there is a problem with map packaging to different platforms .i encountered some similar issues in answerhub (not solved).