Download

Packaging Issues

I am now learning game packaking and read and watched couple tutorials. My project has now error when try to play it, but when try to package lot of errors like: Screen capture - f9d99fe4deac325c80ce7b1915c626aa - Gyazo and Screen capture - 64d416897279862a37dd96de51954c61 - Gyazo . Can anyone help or tell me what is problem. It is odd because the game is working in selected viewport and standalone game without errors or warnings, but when packaking lot of happens and it didn’t work. I am very thankful if someone can help

I see you are using UE 4.7 (binary), and are attempting to package a “match 3” project. Is this the same match 3 that was recently release as an example?

Have you tried using a newer version of the engine (or a different version)?

Edit: What platform are you attempting to package for / any other information can help

I have tried windows and android both. They don’t work, but these errors where in windows packaking. I have used Match 3 package basics, but I have done my own kind of version about that Match 3 game, 9 levels own items etc. I have done this unreal engine 4.7.6 because in newer version game crashes every time, and that same crashing problem has many other match 3 owner and they also have done it with this version 4.7.6 but they haven’t yet tried to package this game. It’s odd that packaking failed, because game is working well and no errors, and I have red many tutorials and settings are same than in these tutorials (sorry for bad english)

This packaking thing is one which i don’t understand. I have tried couple projects in different versions and settings are same with in tutorials, but it always failed.

Sorry didn’t follow up,

Can you post the entire log , unfortunately without seeing the entire thing its hard to tell exactly what went wrong in the packaging. You’ll see in the output “see log C:/users/…/cook.txt” I’m not sure where your project is on your computer but try to post that log.

Personal tip: Open a COPY of your project with a newer version (like 4.8, 4.9, 4.10 see if you have a similar result)

Also it would probably help you more if you post this on answer hub https://answers.unrealengine.com/

no more warnings,but packaking failed. two last log line:
and i watched my log and saw that problems is about some automation tool. there is last line in log maybe packaking failed because of that
MainFrameActions: Packaging (Windows (32-bit)): RunUAT.bat ERROR: AutomationTool was unable to run successfully.
MainFrameActions: Packaging (Windows (32-bit)): BUILD FAILED
maybe problem consider about that automationtool