Packaging Issue(Android)

So I’m trying to package a project in Unreal Engine 5.0 but whenever I try to build it it completes the process immediately and spit out “Packaing complete!” but without anything done.
I’ve been looking at some previous posts like below, but haven’t gotten anything working yet.

Any thoughts on it would be greatly appreciated.


Build output log

LogSlate: Window 'SDK Not Setup' being destroyed
LogUObjectHash: Compacting FUObjectHashTables data took   0.41ms
LogTurnkeySupport: Project requires temp target (ChaosVehiclesPlugin plugin is enabled)
LogLauncherProfile: Unable to use promoted target - ../../../../../UE5/Car/Binaries/Android/ does not exist.
LogMonitoredProcess: Running Serialized UAT: [ cmd.exe /c ""D:/Epic Games Library/UE_5.0/Engine/Build/BatchFiles/RunUAT.bat" -ScriptsForProject="D:/UE5/Car/Car.uproject" Turnkey -command=VerifySdk -platform=Android -UpdateIfNeeded -EditorIO -EditorIOPort=55666  -project="D:/UE5/Car/Car.uproject" BuildCookRun -nop4 -utf8output -nocompileeditor -skipbuildeditor -cook  -project="D:/UE5/Car/Car.uproject"  -unrealexe="D:\Epic Games Library\UE_5.0\Engine\Binaries\Win64\UnrealEditor-Cmd.exe" -platform=Android  -cookflavor=ASTC -ddc=InstalledDerivedDataBackendGraph -installed -stage -archive -package 
-build -compressed -iostore -pak -prereqs -archivedirectory="D:/UE5/PackagedGames" -clientconfig=Development" -nocompile ]
UATHelper: Packaging (Android (ASTC)): Running AutomationTool...
UATHelper: Packaging (Android (ASTC)): 'dotnet' is not recognized as an internal or external command,
UATHelper: Packaging (Android (ASTC)): operable program or batch file.
UATHelper: Packaging (Android (ASTC)): Updating environment variables set by a Turnkey sub-process
UATHelper: Packaging (Android (ASTC)): The system cannot find the path specified.
UATHelper: Packaging (Android (ASTC)): The system cannot find the path specified.

I’m curious to this as well - I’m having a similar issue when compiling in UE5 with this same log.

I did run into the same issues. For me, the installation of the dotnet-sdk-3.1.417-win-x64 from This Microsoft link - at least I can confirm that this definitely worked, having VS2019 installed.

In the meantime 418 and 419 are available, I did not test these - so you might give 3.1.417 at least a try, I can confirm, that it helped in my case.

SDK 6 versions are only for VS2022 as to the microsoft docs.

I did want to follow up as I am actively building now - for me, it was with the PlasticSCM Source Control plugin that was conflicting, I tried various dotnet installations with the same results.

I’m planning on digging into what specifically the plugin was doing to cause the error, but in the meantime I’ve removed it (unnecessary for what I’ve been working on) to move forward. Once I have some time to troubleshoot further, i’ll follow up if helpful.