Packaging is failing in 4.8

Got a similar error, but it only happens when I’ve got Ramas plugin enabled.

MainFrameActions: Packaging (Windows (64-bit)): UnrealBuildTool: [11/12] Link UE4-VictoryBPLibrary.lib
MainFrameActions: Packaging (Windows (64-bit)): UnrealBuildTool: [12/12] Link Project542352352.exe
MainFrameActions: Packaging (Windows (64-bit)): UnrealBuildTool: LINK : fatal error LNK1181: cannot open input file ‘C:\Program Files\Unreal Engine\4.8\Engine\Intermediate\Build\Win64\UE4\Development\Launch\PCLaunch.rc.res’


I’ve tried packaging voor Win32 and Win64, but get the following error message:

LINK : fatal error LNK1181: cannot open input file ‘C:\Program Files\Epic Games\4.8\Engine\Intermediate\Build\Win64\UE4\Development\Launch\PCLaunch.rc.res’

Is there something I can do to fix that?

But do you have the PCLaunch.rc.res file at the location in the error? I don’t.

I disabled the Substance plugin. Now it will package fine.

I don’t. But I believe that’s because the location is a temporary one where the packaging tool stores all the files temporary. So it’s weird that it can’t open it when the file doesn’t exist.

Could you provide the whole log? It should still properly link even with the plugin enabled. I can diagnose the problem from the log.


It should be noted that I randomly got it working 2 times, thought it was due to using a different version of the plugin so I didn’t save the logs for those text

I tried verifying my project, after a while it said that it had backuped this file “BuildConfiguration.xml”. I tried packaging with the plugin and it worked this time.

But the moment I convert my main project and try to package that I get that error again and it makes it so even on the new project that I could previously package without problems with the plugin I now got that same link error again.

Verify the 4.8 version again and the test project I created with the 4.8 version works again. So attempting to package my main project that I converted from 4.7.6 most break some file that all projects use to package them.

Ok, there is definitely an issue in 4.8. We’re looking in to a fix. In the meantime, you can fix the issue by the following:

  1. Create a new code-based project (the template chosen doesn’t matter, I chose FPS)
  2. After the newly created project has been opened in the editor, use explorer to browse to the location of that project on your computer
  3. Search for PCLaunch.rc.res in that project (it will be found in the Intermediate directory)
  4. Copy that file to /Engine/Intermediate/Build/Win64/Development/Launch/ and/or /Engine/Intermediate/Build/Win32/Development/Launch/ (you may have to make the Launch directory)
  5. Open the broken project
  6. Uncheck Rebuild in the Package Settings
  7. Package should now work

Not ideal, but should get you unbroken and still be able to have the enabled plugins.


Workarounds are always good and it works.

I am also using the Substance plugin from Market in 4.8.

My locations were different than posted. (Notice the UE4 dir)

\Epic Games\4.8\Engine\Intermediate\Build\Win32\UE4\Development\Launch

\Epic Games\4.8\Engine\Intermediate\Build\Win64\UE4\Development\Launch

\Epic Games\4.8\Engine\Intermediate\Build\Win64\UE4\Shipping\Launch

\Epic Games\4.8\Engine\Intermediate\Build\Win32\UE4\Shipping\Launch

Though it only seemed to be the 64bit ones that were missing.

Just wanted to say that I had the same problem. Your workaround works for now.

I’m having the same issue, upgraded to 4.8 and now it won’t build, this workaround also didn’t fix it, the project builds successfully but hangs on launch. 4.7.6 build did not hang.