Packaging IOS for distribution not working despite provision and cert being valid

What I trying to do:

So I am developing my game on a Windows PC.

I can build the game fine with development Certificate an mobile provision and deploy to my IOS device.

Now I want to test In-App purchases and to do so I have to upload my game to Itunes connect.

To upload to Itunes connect I think you have to package the game with Distribution Certificate and Distribution mobile provisioning profile from MAC OS.

I ported the game to my Mac and created new distribution certificate and mobile provisioning profile.

Cert and Provisioning shows valid but packaging it just doens’t work (screenshot).

So now I am trying to get it to work for days now and I literally searched through every forum post and tried everything I could find but I can’t get it to work.

What I tried so far:

-Revoke and make new cert and provisioning profile

-copy the provisioning profile to [Projektname]/Build/IOS

-Install the mobile provisioning in Unreal project settings via the import button

-Install the mobile provisioning via xCode by double clicking on it

-When installing via xCode, xCode changes the name of the mobile provision to a string of lettes and numbers. Renamed the mobile provision back to [Projectname].mobileprovision but still doesn’t work

-export the mobile provision, certificate and Keypair(.key, .p12) from Mac to my windows pc and package it there but Unreal engine doesn’t accept the Keypair

-Also isntalled Apple Worldwide Developer Relations Certification Authority in the Keychain access on my Mac

-Also in Keychain Acces set the Key paired with the Distribution Certificate to allow all aplications to access this item


The game is Blueprint only.

Also note in the message log it says a provision is required for deploying your app to the device but I don’t want to deploy to device?! I want to package a build for distribution.

my Mac:

-macOS Sierra version 10.12.6

-xCode version 8.3.3

my Windows PC:

-Windows 8.1 64bit

Hi NightSoundGames,

It’s quite a shame that your question has gone unanswered… I’m exactly in the same place as you and am struggling to get the engine to accept a perfect valid distribution provision. I wondered if you have found a solution to your problem - any guidance you could give would be massively appreciated.

Best regards,

I have exactly the same problem: it deployed smoothly with paid certificate yesterday (30-08-2018) and suddenly keeps complaining provision file couldn’t be found today ( less than 20 hours ), and nothing has ever been changed, just reopen the project and press “launch”…the two red errors instantly show up.

It makes zero sense for UE fixated on this annoying certificate/provision business, seriously, what’s the point?

I was having the same issue and realised that the problem was that while I had created a brand new distribution certificate, I had forgotten that I also needed a distribution provisioning profile. After I got both the certificate and provision, both for distribution and not development, it went ahead to try to cook.

Unfortunately I’m having a myriad of other packaging issues at the moment that I’m trying to solve, but none related to this issue. Hope this helps.

Export it to a Xcode project and let Xcode handle the Distribution automatically.